Infinite loop and Blind SSRF found inside the Webfinger mechanism in @fedify/fedify
CVE-2025-23221GHSA-c59p-wq67-24wx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fedify/fedify 1.3.4, 1.2.11, 1.1.11, 1.0.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @fedify/fedify
- Affected
- >= 1.0.13, <= 1.0.13>= 1.1.10, <= 1.1.10>= 1.2.10, <= 1.2.10>= 1.3.3, <= 1.3.3
- Fixed in
- 1.1.11, 1.2.11, 1.0.14, 1.3.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c59p-wq67-24wx lists affected ranges: npm @fedify/fedify >=1.0.13 =1.1.10 =1.2.10 =1.3.3 <1.3.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c59p-wq67-24wx lists affected ranges: npm @fedify/fedify >=1.0.13 =1.1.10 =1.2.10 =1.3.3 <=1.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:L
- EPSS
- CVE-2025-23221: 0.62% estimated exploitation activity in the next 30 days; percentile 49.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary This vulnerability allows a user to maneuver the Webfinger mechanism to perform a GET request to any internal resource on any Host, Port, URL combination regardless of present security mechanisms, and forcing the victim’s server into an infinite loop causing Denial of Service. Moreover, this issue can also be maneuvered into performing a Blind SSRF attack. Details The Webfinger endpoint takes a remote domain for checking accounts as a feature, however, as per the ActivityPub spec (https://www.w3.org/TR/activitypub/#security-considerations), on the security considerations section at B.3, access to Localhost services should be prevented while running in production. The lookupWebFinger function, responsible for returning an actor handler for received actor objects from a remote server, can be abused to perform a Denial of Service (DoS) and Blind SSRF attacks while attempting to resolve a malicious actor’s object. On Fedify, two client-facing functions implement the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-c59p-wq67-24wx
- Revision 1 · created ·
Published from osv record GHSA-c59p-wq67-24wx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-23221 Advisory: Infinite loop and Blind SSRF found inside the Webfinger mechanism in @fedify/fedify IDs: CVE-2025-23221, GHSA-c59p-wq67-24wx Record: https://patchnext.com/advisories/cve-2025-23221 (revision 2, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @fedify/fedify 1.3.4, 1.2.11, 1.1.11, 1.0.14. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @fedify/fedify: affected >= 1.0.13, <= 1.0.13; >= 1.1.10, <= 1.1.10; >= 1.2.10, <= 1.2.10; >= 1.3.3, <= 1.3.3; fixed in 1.1.11, 1.2.11, 1.0.14, 1.3.4 ## Suggested inspection (read-only) - `npm ls @fedify/fedify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @fedify/fedify. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c59p-wq67-24wx (OSV record GHSA-c59p-wq67-24wx lists affected ranges: npm @fedify/fedify >=1.0.13 =1.1.10 =1.2.10 =1.3.3 <1.3.4 (fixed)) - Verified: https://github.com/advisories/GHSA-c59p-wq67-24wx (GitHub-reviewed advisory GHSA-c59p-wq67-24wx lists affected ranges: npm @fedify/fedify >=1.0.13 =1.1.10 =1.2.10 =1.3.3 <=1.3.3) Commands are suggestions: review each one before running it.
Loading voting…