Mitmweb API Authentication Bypass Using Proxy Server
CVE-2025-23217GHSA-wg33-5h85-7q5p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mitmproxy 11.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mitmproxy
- Affected
- < 11.1.2
- Fixed in
- 11.1.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wg33-5h85-7q5p lists affected ranges: PyPI mitmproxy >=0 <11.1.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wg33-5h85-7q5p lists affected ranges: PyPI mitmproxy >=0 <11.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-23217: 0.87% estimated exploitation activity in the next 30 days; percentile 58.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In mitmweb 11.1.0 and below, a malicious client can use mitmweb's proxy server (bound to :8080 by default) to access mitmweb's internal API (bound to 127.0.0.1:8081 by default). In other words, while the client cannot access the API directly (good), they can access the API through the proxy (bad). An attacker may be able to escalate this SSRF-style access to remote code execution. The mitmproxy and mitmdump tools are unaffected. Only mitmweb is affected. The blockglobal option, which is enabled by default, blocks connections originating from publicly-routable IP addresses in the proxy. The attacker needs to be in the same local network. Patches The vulnerability has been fixed in mitmproxy 11.1.2 and above. Acknowledgements We thank Stefan Grönke (@gronke) for reporting this vulnerability as part of a security audit by Radically Open Security. This audit was supported by the NGI0 Entrust fund established by NLnet. Timeline - 2025-01-14: Received initial report. - 2025-01-14:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wg33-5h85-7q5p
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-wg33-5h85-7q5p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-23217 Advisory: Mitmweb API Authentication Bypass Using Proxy Server IDs: CVE-2025-23217, GHSA-wg33-5h85-7q5p Record: https://patchnext.com/advisories/cve-2025-23217 (revision 3, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mitmproxy 11.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mitmproxy: affected < 11.1.2; fixed in 11.1.2 ## Suggested inspection (read-only) - `python -m pip show mitmproxy`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mitmproxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wg33-5h85-7q5p (OSV record GHSA-wg33-5h85-7q5p lists affected ranges: PyPI mitmproxy >=0 <11.1.2 (fixed)) - Verified: https://github.com/advisories/GHSA-wg33-5h85-7q5p (GitHub-reviewed advisory GHSA-wg33-5h85-7q5p lists affected ranges: PyPI mitmproxy >=0 <11.1.2) Commands are suggestions: review each one before running it.
Loading voting…