Skip to content

← Actionable
Medium, CVSS 4.8

PhpSpreadsheet allows bypassing of XSS sanitizer using the javascript protocol and special characters

CVE-2025-23210GHSA-r57h-547h-w24f

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpoffice/phpexcel

    Affected
    <= 1.8.2
    Fixed in
    no fixed version recorded
  • Packagist phpoffice/phpspreadsheet

    Affected
    >= 3.0.0, < 3.9.0< 1.29.9>= 2.2.0, < 2.3.7>= 2.0.0, < 2.1.8
    Fixed in
    3.9.0, 2.3.7, 1.29.9, 2.1.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2025-23210: 0.41% estimated exploitation activity in the next 30 days; percentile 35.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Product: PhpSpreadsheet Version: 3.8.0 CWE-ID: CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') CVSS vector v.3.1: 5.4 (AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N) CVSS vector v.4.0: 4.8 (AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N) Description: an attacker can use special characters, so that the library processes the javascript protocol with special characters and generates an HTML link Impact: executing arbitrary JavaScript code in the browser Vulnerable component: class PhpOffice\PhpSpreadsheet\Writer\Html, method generateRow Exploitation conditions: a user viewing a specially generated xml file Mitigation: additional sanitization of special characters in a string Researcher: Igor Sak-Sakovskiy (Positive Technologies) Research The researcher discovered zero-day vulnerability Bypass XSS sanitizer using the javascript protocol and special characters in Phpspreadsheet. The following code is written on the server, which translates the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r57h-547h-w24f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-23210

Advisory: PhpSpreadsheet allows bypassing of XSS sanitizer using the javascript protocol and special characters
IDs: CVE-2025-23210, GHSA-r57h-547h-w24f
Record: https://patchnext.com/advisories/cve-2025-23210 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: phpoffice/phpspreadsheet 3.9.0, 2.3.7, 2.1.8, 1.29.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpoffice/phpexcel: affected <= 1.8.2
- Packagist phpoffice/phpspreadsheet: affected >= 3.0.0, < 3.9.0; < 1.29.9; >= 2.2.0, < 2.3.7; >= 2.0.0, < 2.1.8; fixed in 3.9.0, 2.3.7, 1.29.9, 2.1.8

## Suggested inspection (read-only)
- Packagist phpoffice/phpexcel: check the installed version with your package manager.
- Packagist phpoffice/phpspreadsheet: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpoffice/phpexcel, phpoffice/phpspreadsheet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r57h-547h-w24f (GitHub-reviewed advisory GHSA-r57h-547h-w24f lists affected ranges: Packagist phpoffice/phpspreadsheet >=3.0.0 =0 =2.2.0 =2.0.0 =0 <=1.8.2)

Commands are suggestions: review each one before running it.

Loading voting…