Skip to content

← Actionable
Medium, CVSS 4.4

API Platform Core does not call GraphQl securityAfterResolver

CVE-2025-23204GHSA-7mxx-3cgm-xxv3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (api-platform/core 3.3.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.4 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N
EPSS
  • CVE-2025-23204: 0.30% estimated exploitation activity in the next 30 days; percentile 22.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A security check that gets called after GraphQl resolvers is always replaced by another one as there's no break in this clause: https://github.com/api-platform/core/pull/6444/files#diff-09e3c2cfe12a2ce65bd6c983c7ca6bfcf783f852b8d0554bb938e8ebf5e5fa65R56 https://github.com/soyuka/core/blob/7e2e8f9ff322ac5f6eb5f65baf432bffdca0fd51/src/Symfony/Security/State/AccessCheckerProvider.php#L49-L57 PoC Create a graphql endpoint with a security after resolver. Impact As this fallsback to security, the impact is there only when there's only a security after resolver and none inside security. The test at https://github.com/api-platform/core/pull/6444 is probably broken.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7mxx-3cgm-xxv3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-23204

Advisory: API Platform Core does not call GraphQl securityAfterResolver
IDs: CVE-2025-23204, GHSA-7mxx-3cgm-xxv3
Record: https://patchnext.com/advisories/cve-2025-23204 (revision 1, source checked 26 Oct 2026, 14:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: api-platform/core 3.3.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist api-platform/core: affected >= 3.3.8, < 3.3.15; fixed in 3.3.15

## Suggested inspection (read-only)
- Packagist api-platform/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on api-platform/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7mxx-3cgm-xxv3 (GitHub-reviewed advisory GHSA-7mxx-3cgm-xxv3 lists affected ranges: Packagist api-platform/core >=3.3.8 <3.3.15)

Commands are suggestions: review each one before running it.

Loading voting…