Skip to content

← Actionable
Medium, CVSS 5.4

Librenms has a reflected XSS on error alert

CVE-2025-23201GHSA-g84x-g96g-rcjc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 24.11.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-23201: 0.43% estimated exploitation activity in the next 30 days; percentile 36.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

XSS on the parameters:/addhost - param: community of Librenms versions 24.10.1 (https://github.com/librenms/librenms) allows remote attackers to inject malicious scripts. When a user views or interacts with the page displaying the data, the malicious script executes immediately, leading to potential unauthorized actions or data exposure. Proof of Concept: 1. Navigate to the /addhost path. 2. Fill in all required fields. 3. In the Community field, enter the following payload: "<img src=a onerror="alert(1)". 4. Submit the form to save changes. 5 The script will execute when the error alert "No reply with community + payload" appears. Impact: Execution of Malicious Code

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g84x-g96g-rcjc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-23201

Advisory: Librenms has a reflected XSS on error alert
IDs: CVE-2025-23201, GHSA-g84x-g96g-rcjc
Record: https://patchnext.com/advisories/cve-2025-23201 (revision 1, source checked 26 Oct 2026, 14:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 24.11.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist librenms/librenms: affected <= 24.10.1; fixed in 24.11.0

## Suggested inspection (read-only)
- Packagist librenms/librenms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on librenms/librenms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g84x-g96g-rcjc (GitHub-reviewed advisory GHSA-g84x-g96g-rcjc lists affected ranges: Packagist librenms/librenms >=0 <=24.10.1)

Commands are suggestions: review each one before running it.

Loading voting…