Skip to content

← Actionable
Unrated

Corrupted pointer in node::fs::ReadFileUtf8(const FunctionCallbackInfo & args) when args[0] is a string.

CVE-2025-23165

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 22.15.1, 20.19.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • runtime node

    Affected
    >= 20.0.0, < 20.19.2>= 22.0.0, < 22.15.1
    Fixed in
    22.15.1, 20.19.2

Sources

  • nodejs.org runtime security intelligence

    The nodejs.org release index dates the first patched release for CVE-2025-23165 to 2025-05-14.

    VerifiedObserved Official nodejs.org release index (dist/index.json).

  • raw.githubusercontent.com runtime security intelligence

    Node.js security working group core entry 151 lists CVE-2025-23165 affecting node >=20.0.0 =22.0.0 <22.15.1

    VerifiedObserved Structured Node.js security-wg core vulnerability record maintained by the Node.js project.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2025-23165: 0.56% estimated exploitation activity in the next 30 days; percentile 46.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Node.js, the `ReadFileUtf8` internal binding leaks memory due to a corrupted pointer in `uv_fs_s.file`: a UTF-16 path buffer is allocated but subsequently overwritten when the file descriptor is set. This results in an unrecoverable memory leak on every call. Repeated use can cause unbounded memory growth, leading to a denial of service. Impact: * This vulnerability affects APIs relying on `ReadFileUtf8` on Node.js release lines: v20 and v22.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · published ·

    Published from vendor_advisory record nodejs-security-wg:core:151

  2. Revision 1 · created ·

    Created from vendor_advisory record nodejs-security-wg:core:151

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-23165

Advisory: Corrupted pointer in node::fs::ReadFileUtf8(const FunctionCallbackInfo & args) when args[0] is a string.
IDs: CVE-2025-23165
Record: https://patchnext.com/advisories/cve-2025-23165 (revision 2, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node 22.15.1, 20.19.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- runtime node: affected >= 20.0.0, < 20.19.2; >= 22.0.0, < 22.15.1; fixed in 22.15.1, 20.19.2

## Suggested inspection (read-only)
- runtime node: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2025-23165 to 2025-05-14.)
- Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/151.json (Node.js security working group core entry 151 lists CVE-2025-23165 affecting node >=20.0.0 =22.0.0 <22.15.1)

Commands are suggestions: review each one before running it.

Loading voting…