Skip to content

← Actionable
Medium, CVSS 6.5

Cilium has an information leakage via insecure default Hubble UI CORS header

CVE-2025-23047GHSA-h78m-j95m-5356

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cilium/cilium 1.16.6, 1.15.13, 1.14.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/cilium/cilium

    Affected
    >= 1.14.0, < 1.14.19>= 1.15.0, < 1.15.13>= 1.16.0, < 1.16.6
    Fixed in
    1.15.13, 1.16.6, 1.14.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-23047: 0.49% estimated exploitation activity in the next 30 days; percentile 42.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact For users who deploy Hubble UI using either Cilium CLI or via the Cilium Helm chart, an insecure default Access-Control-Allow-Origin header value could lead to sensitive data exposure. A user with access to a Hubble UI instance affected by this issue could leak configuration details about the Kubernetes cluster which Hubble UI is monitoring, including node names, IP addresses, and other metadata about workloads and the cluster networking configuration. In order for this vulnerability to be exploited, a victim would have to first visit a malicious page. Patches This issue was patched in https://github.com/cilium/cilium/commit/a3489f190ba6e87b5336ee685fb6c80b1270d06d This issue affects: - Cilium between v1.14.0 and v1.14.18 inclusive - Cilium between v1.15.0 and v1.15.12 inclusive - Cilium between v1.16.0 and v1.16.5 inclusive This issue is patched in: - Cilium v1.14.19 - Cilium v1.15.13 - Cilium v1.16.6 Workarounds Users who deploy Hubble UI using the Cilium Helm chart directly…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h78m-j95m-5356

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-23047

Advisory: Cilium has an information leakage via insecure default Hubble UI CORS header
IDs: CVE-2025-23047, GHSA-h78m-j95m-5356
Record: https://patchnext.com/advisories/cve-2025-23047 (revision 1, source checked 26 Oct 2026, 15:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/cilium/cilium 1.16.6, 1.15.13, 1.14.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/cilium/cilium: affected >= 1.14.0, < 1.14.19; >= 1.15.0, < 1.15.13; >= 1.16.0, < 1.16.6; fixed in 1.15.13, 1.16.6, 1.14.19

## Suggested inspection (read-only)
- Go github.com/cilium/cilium: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/cilium/cilium.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h78m-j95m-5356 (GitHub-reviewed advisory GHSA-h78m-j95m-5356 lists affected ranges: Go github.com/cilium/cilium >=1.14.0 =1.15.0 =1.16.0 <1.16.6)

Commands are suggestions: review each one before running it.

Loading voting…