Skip to content

← Actionable
Medium, CVSS 6.1

jte's HTML templates containing Javascript template strings are subject to XSS

CVE-2025-23026GHSA-vh22-6c6h-rm8q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gg.jte:jte 3.1.16; gg.jte:jte-runtime 3.1.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2025-23026: 0.30% estimated exploitation activity in the next 30 days; percentile 23.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Jte HTML templates with script tags or script attributes that include a Javascript template string (backticks) are subject to XSS. Details The javaScriptBlock and javaScriptAttribute methods in the Escape class (source) do not escape backticks, which are used for Javascript template strings. Dollar signs in template strings should also be escaped as well to prevent undesired interpolation. PoC 1. Use the Jte Gradle Plugin with the following code in src/jte/xss.jte: 2. Use the following Java code to demonstrate the XSS vulnerability: Impact HTML templates rendered by Jte's OwaspHtmlTemplateOutput in versions less than or equal to 3.1.15 with script tags or script attributes that contain Javascript template strings (backticks) are vulnerable.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vh22-6c6h-rm8q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-23026

Advisory: jte's HTML templates containing Javascript template strings are subject to XSS
IDs: CVE-2025-23026, GHSA-vh22-6c6h-rm8q
Record: https://patchnext.com/advisories/cve-2025-23026 (revision 1, source checked 26 Oct 2026, 16:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gg.jte:jte 3.1.16; gg.jte:jte-runtime 3.1.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven gg.jte:jte: affected <= 3.1.15; fixed in 3.1.16
- Maven gg.jte:jte-runtime: affected <= 3.1.15; fixed in 3.1.16

## Suggested inspection (read-only)
- Maven gg.jte:jte: check the installed version with your package manager.
- Maven gg.jte:jte-runtime: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gg.jte:jte, gg.jte:jte-runtime.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vh22-6c6h-rm8q (GitHub-reviewed advisory GHSA-vh22-6c6h-rm8q lists affected ranges: Maven gg.jte:jte >=0 =0 <=3.1.15)

Commands are suggestions: review each one before running it.

Loading voting…