XWiki Realtime WYSIWYG Editor extension allows privilege escalation (PR) through realtime WYSIWYG editing
CVE-2025-23025GHSA-rmm7-r7wr-xpfg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui 16.6.0-rc-1, 16.4.1, 15.10.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui
- Affected
- >= 13.9-rc-1, < 15.10.12>= 16.0.0-rc-1, < 16.4.1>= 16.5.0-rc-1, < 16.6.0-rc-1
- Fixed in
- 15.10.12, 16.4.1, 16.6.0-rc-1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rmm7-r7wr-xpfg lists affected ranges: Maven org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui >=13.9-rc-1 =16.0.0-rc-1 =16.5.0-rc-1 <16.6.0-rc-1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2025-23025: 0.42% estimated exploitation activity in the next 30 days; percentile 36.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact NOTE: The Realtime WYSIWYG Editor extension was experimental, and thus not recommended, in the versions affected by this vulnerability. It has become enabled by default, and thus recommended, starting with XWiki 16.9.0. A user with only edit right can join a realtime editing session where others, that where already there or that may join later, have script or programming access rights. This user can then insert script rendering macros that are executed for those users in the realtime session that have script or programming rights. The inserted scripts can be used to gain more access rights. Here's an example that works with XWiki 15.10.9+ and 16.2.0+: the attacker starts editing a wiki page in realtime (for which they have edit right) another user, with script or programming access right joins the editing session (e.g. by clicking on a link / URL provided by the attacker) the attacker inserts a script rendering macro, say {{velocity}}I can run scripts{{/velocity}}, in the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rmm7-r7wr-xpfg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-23025 Advisory: XWiki Realtime WYSIWYG Editor extension allows privilege escalation (PR) through realtime WYSIWYG editing IDs: CVE-2025-23025, GHSA-rmm7-r7wr-xpfg Record: https://patchnext.com/advisories/cve-2025-23025 (revision 1, source checked 26 Oct 2026, 16:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui 16.6.0-rc-1, 16.4.1, 15.10.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui: affected >= 13.9-rc-1, < 15.10.12; >= 16.0.0-rc-1, < 16.4.1; >= 16.5.0-rc-1, < 16.6.0-rc-1; fixed in 15.10.12, 16.4.1, 16.6.0-rc-1 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rmm7-r7wr-xpfg (GitHub-reviewed advisory GHSA-rmm7-r7wr-xpfg lists affected ranges: Maven org.xwiki.platform:xwiki-platform-realtime-wysiwyg-ui >=13.9-rc-1 =16.0.0-rc-1 =16.5.0-rc-1 <16.6.0-rc-1) Commands are suggestions: review each one before running it.
Loading voting…