RoadRunner is at risk of HTTP Request/Response Smuggling through vulnerable dependency
CVE-2025-22871GHSA-g9pc-8g42-g6vq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (spiral/roadrunner 2025.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist spiral/roadrunner
- Affected
- < 2025.1.0
- Fixed in
- 2025.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g9pc-8g42-g6vq lists affected ranges: Packagist spiral/roadrunner >=0 <2025.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2025-22871: 0.84% estimated exploitation activity in the next 30 days; percentile 57.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The net/http package dependency used by RoadRunner improperly accepts a bare LF as a line terminator in chunked data chunk-size lines. This can permit request smuggling if a net/http server is used in conjunction with a server that incorrectly accepts a bare LF as part of a chunk-ext.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g9pc-8g42-g6vq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-22871 Advisory: RoadRunner is at risk of HTTP Request/Response Smuggling through vulnerable dependency IDs: CVE-2025-22871, GHSA-g9pc-8g42-g6vq Record: https://patchnext.com/advisories/cve-2025-22871 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: spiral/roadrunner 2025.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist spiral/roadrunner: affected < 2025.1.0; fixed in 2025.1.0 ## Suggested inspection (read-only) - Packagist spiral/roadrunner: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on spiral/roadrunner. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g9pc-8g42-g6vq (GitHub-reviewed advisory GHSA-g9pc-8g42-g6vq lists affected ranges: Packagist spiral/roadrunner >=0 <2025.1.0) Commands are suggestions: review each one before running it.
Loading voting…