golang.org/x/oauth2 Improper Validation of Syntactic Correctness of Input vulnerability
CVE-2025-22868GHSA-6v2p-p543-phr9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (golang.org/x/oauth2 0.27.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.27.0
- Fixed in
- 0.27.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6v2p-p543-phr9 lists affected ranges: Go golang.org/x/oauth2 >=0 <0.27.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-22868: 0.87% estimated exploitation activity in the next 30 days; percentile 58.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An attacker can pass a malicious malformed token which causes unexpected memory to be consumed during parsing.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6v2p-p543-phr9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-22868 Advisory: golang.org/x/oauth2 Improper Validation of Syntactic Correctness of Input vulnerability IDs: CVE-2025-22868, GHSA-6v2p-p543-phr9 Record: https://patchnext.com/advisories/cve-2025-22868 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: golang.org/x/oauth2 0.27.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go golang.org/x/oauth2: affected < 0.27.0; fixed in 0.27.0 ## Suggested inspection (read-only) - Go golang.org/x/oauth2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on golang.org/x/oauth2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6v2p-p543-phr9 (GitHub-reviewed advisory GHSA-6v2p-p543-phr9 lists affected ranges: Go golang.org/x/oauth2 >=0 <0.27.0) Commands are suggestions: review each one before running it.
Loading voting…