Spring Boot EndpointRequest.to() creates wrong matcher if actuator endpoint is not exposed
CVE-2025-22235GHSA-rc42-6c7j-7h5r
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.boot:spring-boot
- Affected
- <= 2.7.24.2>= 3.1.0, <= 3.1.15.2>= 3.2.0, <= 3.2.13.2>= 3.3.0, <= 3.3.10>= 3.4.0, <= 3.4.4
- Fixed in
- 3.3.11, 3.4.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rc42-6c7j-7h5r lists affected ranges: Maven org.springframework.boot:spring-boot >=0 =3.1.0 =3.2.0 =3.3.0 =3.4.0 <=3.4.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2025-22235: 0.44% estimated exploitation activity in the next 30 days; percentile 38.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
EndpointRequest.to() creates a matcher for null/ if the actuator endpoint, for which the EndpointRequest has been created, is disabled or not exposed. Your application may be affected by this if all the following conditions are met: You use Spring Security EndpointRequest.to() has been used in a Spring Security chain configuration The endpoint which EndpointRequest references is disabled or not exposed via web Your application handles requests to /null and this path needs protection You are not affected if any of the following is true: You don't use Spring Security You don't use EndpointRequest.to() The endpoint which EndpointRequest.to() refers to is enabled and is exposed Your application does not handle requests to /null or this path does not need protection
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rc42-6c7j-7h5r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-22235 Advisory: Spring Boot EndpointRequest.to() creates wrong matcher if actuator endpoint is not exposed IDs: CVE-2025-22235, GHSA-rc42-6c7j-7h5r Record: https://patchnext.com/advisories/cve-2025-22235 (revision 1, source checked 26 Oct 2026, 16:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.springframework.boot:spring-boot 3.4.5, 3.3.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.boot:spring-boot: affected <= 2.7.24.2; >= 3.1.0, <= 3.1.15.2; >= 3.2.0, <= 3.2.13.2; >= 3.3.0, <= 3.3.10; >= 3.4.0, <= 3.4.4; fixed in 3.3.11, 3.4.5 ## Suggested inspection (read-only) - Maven org.springframework.boot:spring-boot: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.boot:spring-boot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rc42-6c7j-7h5r (GitHub-reviewed advisory GHSA-rc42-6c7j-7h5r lists affected ranges: Maven org.springframework.boot:spring-boot >=0 =3.1.0 =3.2.0 =3.3.0 =3.4.0 <=3.4.4) Commands are suggestions: review each one before running it.
Loading voting…