Spring Security Does Not Enforce Password Length
CVE-2025-22228GHSA-mg83-c7gq-rv5c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.security:spring-security-crypto 6.4.4, 6.3.8, 6.2.10, 6.1.14, 6.0.16, 5.8.18, 5.7.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.security:spring-security-crypto
- Affected
- >= 6.3.0, < 6.3.8>= 6.4.0, < 6.4.4>= 6.2.0, <= 6.2.9>= 6.1.0, <= 6.1.13>= 6.0.0, <= 6.0.15>= 5.8.0, <= 5.8.17<= 5.7.15
- Fixed in
- 6.2.10, 6.3.8, 5.7.16, 6.0.16, 5.8.18, 6.1.14, 6.4.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mg83-c7gq-rv5c lists affected ranges: Maven org.springframework.security:spring-security-crypto >=6.3.0 =6.4.0 =6.2.0 =6.1.0 =6.0.0 =5.8.0 =0 <=5.7.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2025-22228: 0.61% estimated exploitation activity in the next 30 days; percentile 49.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
BCryptPasswordEncoder.matches(CharSequence,String) will incorrectly return true for passwords larger than 72 characters as long as the first 72 characters are the same.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mg83-c7gq-rv5c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-22228 Advisory: Spring Security Does Not Enforce Password Length IDs: CVE-2025-22228, GHSA-mg83-c7gq-rv5c Record: https://patchnext.com/advisories/cve-2025-22228 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.springframework.security:spring-security-crypto 6.4.4, 6.3.8, 6.2.10, 6.1.14, 6.0.16, 5.8.18, 5.7.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.security:spring-security-crypto: affected >= 6.3.0, < 6.3.8; >= 6.4.0, < 6.4.4; >= 6.2.0, <= 6.2.9; >= 6.1.0, <= 6.1.13; >= 6.0.0, <= 6.0.15; >= 5.8.0, <= 5.8.17; <= 5.7.15; fixed in 6.2.10, 6.3.8, 5.7.16, 6.0.16, 5.8.18, 6.1.14, 6.4.4 ## Suggested inspection (read-only) - Maven org.springframework.security:spring-security-crypto: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.security:spring-security-crypto. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mg83-c7gq-rv5c (GitHub-reviewed advisory GHSA-mg83-c7gq-rv5c lists affected ranges: Maven org.springframework.security:spring-security-crypto >=6.3.0 =6.4.0 =6.2.0 =6.1.0 =6.0.0 =5.8.0 =0 <=5.7.15) Commands are suggestions: review each one before running it.
Loading voting…