Skip to content

← Actionable
Medium, CVSS 6.8amended

Use of Insufficiently Random Values in undici

CVE-2025-22150GHSA-c76h-2ccp-4975

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 7.2.3, 6.21.1, 5.28.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm undici

    Affected
    >= 4.5.0, < 5.28.5>= 6.0.0, < 6.21.1>= 7.0.0, < 7.2.3
    Fixed in
    5.28.5, 7.2.3, 6.21.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2025-22150: 0.76% estimated exploitation activity in the next 30 days; percentile 55.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Undici fetch() uses Math.random() to choose the boundary for a multipart/form-data request. It is known that the output of Math.random() can be predicted if several of its generated values are known. If there is a mechanism in an app that sends multipart requests to an attacker-controlled website, they can use this to leak the necessary values. Therefore, An attacker can tamper with the requests going to the backend APIs if certain conditions are met. Patches This is fixed in 5.28.5; 6.21.1; 7.2.3. Workarounds Do not issue multipart requests to attacker controlled servers. References https://hackerone.com/reports/2913312 https://blog.securityevaluators.com/hacking-the-javascript-lottery-80cc437e3b7f

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-c76h-2ccp-4975

  2. Revision 1 · created ·

    Published from osv record GHSA-c76h-2ccp-4975

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-22150

Advisory: Use of Insufficiently Random Values in undici
IDs: CVE-2025-22150, GHSA-c76h-2ccp-4975
Record: https://patchnext.com/advisories/cve-2025-22150 (revision 2, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: undici 7.2.3, 6.21.1, 5.28.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm undici: affected >= 4.5.0, < 5.28.5; >= 6.0.0, < 6.21.1; >= 7.0.0, < 7.2.3; fixed in 5.28.5, 7.2.3, 6.21.1

## Suggested inspection (read-only)
- `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on undici.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c76h-2ccp-4975 (OSV record GHSA-c76h-2ccp-4975 lists affected ranges: npm undici >=4.5.0 =6.0.0 =7.0.0 <7.2.3 (fixed))
- Verified: https://github.com/advisories/GHSA-c76h-2ccp-4975 (GitHub-reviewed advisory GHSA-c76h-2ccp-4975 lists affected ranges: npm undici >=4.5.0 =6.0.0 =7.0.0 <7.2.3)

Commands are suggestions: review each one before running it.

Loading voting…