Sentry's improper authentication on SAML SSO process allows user impersonation
CVE-2025-22146GHSA-7pq6-v88g-wf3w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sentry 25.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sentry
- Affected
- >= 21.12.0, < 25.1.0
- Fixed in
- 25.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7pq6-v88g-wf3w lists affected ranges: PyPI sentry >=21.12.0 <25.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7pq6-v88g-wf3w lists affected ranges: PyPI sentry >=21.12.0 <25.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2025-22146: 0.61% estimated exploitation activity in the next 30 days; percentile 49.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A critical vulnerability was discovered in the SAML SSO implementation of Sentry. It was reported to us via our private bug bounty program. The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability. Patches - Sentry SaaS: The fix was deployed on Jan 14, 2025. - Self-Hosted Sentry: If only a single organization is allowed (SENTRYSINGLEORGANIZATION = True), then no action is needed. Otherwise, users should upgrade to version 25.1.0 or higher. Workarounds No known workarounds. References - https://github.com/getsentry/sentry/pull/83407
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7pq6-v88g-wf3w
- Revision 1 · created ·
Published from osv record GHSA-7pq6-v88g-wf3w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-22146 Advisory: Sentry's improper authentication on SAML SSO process allows user impersonation IDs: CVE-2025-22146, GHSA-7pq6-v88g-wf3w Record: https://patchnext.com/advisories/cve-2025-22146 (revision 2, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sentry 25.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sentry: affected >= 21.12.0, < 25.1.0; fixed in 25.1.0 ## Suggested inspection (read-only) - `python -m pip show sentry`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sentry. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7pq6-v88g-wf3w (OSV record GHSA-7pq6-v88g-wf3w lists affected ranges: PyPI sentry >=21.12.0 <25.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7pq6-v88g-wf3w (GitHub-reviewed advisory GHSA-7pq6-v88g-wf3w lists affected ranges: PyPI sentry >=21.12.0 <25.1.0) Commands are suggestions: review each one before running it.
Loading voting…