Skip to content

← Actionable
Medium, CVSS 5.1

Cross-Site Scripting (XSS) vulnerability in generateNavigation() function in PhpSpreadsheet

CVE-2025-22131GHSA-79xx-vf93-p7cx

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpoffice/phpexcel

    Affected
    <= 1.8.2
    Fixed in
    no fixed version recorded
  • Packagist phpoffice/phpspreadsheet

    Affected
    >= 3.0.0, < 3.8.0< 1.29.8>= 2.0.0, < 2.1.7>= 2.2.0, < 2.3.6
    Fixed in
    3.8.0, 2.1.7, 2.3.6, 1.29.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2025-22131: 0.40% estimated exploitation activity in the next 30 days; percentile 33.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The researcher discovered zero-day vulnerability Cross-Site Scripting (XSS) vulnerability in the code which translates the XLSX file into a HTML representation and displays it in the response. Details When generating the HTML from an xlsx file containing multiple sheets, a navigation menu is created. This menu includes the sheet names, which are not sanitized. As a result, an attacker can exploit this vulnerability to execute JavaScript code. PoC 1. Create an XLSX file with multiple sheets : 2. Generate the HTML content 3. Enjoy Impact XSS can cause a variety of problems for the end user that range in severity from an annoyance to complete account compromise. Example of impacts : - Disclosure of the user’s session cookie, allowing an attacker to hijack the user’s session and take over the account (Only if HttpOnly cookie's flag is set to false). - Redirecting the user to some other page or site (like phishing websites) - Modifying the content of the current page (add a fake…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-79xx-vf93-p7cx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-22131

Advisory: Cross-Site Scripting (XSS) vulnerability in generateNavigation() function in PhpSpreadsheet
IDs: CVE-2025-22131, GHSA-79xx-vf93-p7cx
Record: https://patchnext.com/advisories/cve-2025-22131 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: phpoffice/phpspreadsheet 3.8.0, 2.3.6, 2.1.7, 1.29.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpoffice/phpexcel: affected <= 1.8.2
- Packagist phpoffice/phpspreadsheet: affected >= 3.0.0, < 3.8.0; < 1.29.8; >= 2.0.0, < 2.1.7; >= 2.2.0, < 2.3.6; fixed in 3.8.0, 2.1.7, 2.3.6, 1.29.8

## Suggested inspection (read-only)
- Packagist phpoffice/phpexcel: check the installed version with your package manager.
- Packagist phpoffice/phpspreadsheet: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpoffice/phpexcel, phpoffice/phpspreadsheet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-79xx-vf93-p7cx (GitHub-reviewed advisory GHSA-79xx-vf93-p7cx lists affected ranges: Packagist phpoffice/phpspreadsheet >=3.0.0 =0 =2.0.0 =2.2.0 =0 <=1.8.2)

Commands are suggestions: review each one before running it.

Loading voting…