Skip to content

← Actionable
Medium, CVSS 5.3

Soft Serve vulnerable to path traversal attacks

CVE-2025-22130GHSA-j4jw-m6xr-fv6c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/charmbracelet/soft-serve 0.8.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-22130: 0.70% estimated exploitation activity in the next 30 days; percentile 53.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Path traversal attack gives access to existing non-admin users to access and take over other user's repositories. A malicious user then can modify, delete, and arbitrarily repositories as if they were an admin user without explicitly giving them permissions. Patches This is patched in v0.8.2 Workarounds Single user set-ups are not affected. This only affects multi-user Soft Serve set-ups that enable repository creation for users. Otherwise, upgrading is necessary to circumvent the attack.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j4jw-m6xr-fv6c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-22130

Advisory: Soft Serve vulnerable to path traversal attacks
IDs: CVE-2025-22130, GHSA-j4jw-m6xr-fv6c
Record: https://patchnext.com/advisories/cve-2025-22130 (revision 1, source checked 26 Oct 2026, 15:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/charmbracelet/soft-serve 0.8.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/charmbracelet/soft-serve: affected < 0.8.2; fixed in 0.8.2

## Suggested inspection (read-only)
- Go github.com/charmbracelet/soft-serve: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/charmbracelet/soft-serve.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j4jw-m6xr-fv6c (GitHub-reviewed advisory GHSA-j4jw-m6xr-fv6c lists affected ranges: Go github.com/charmbracelet/soft-serve >=0 <0.8.2)

Commands are suggestions: review each one before running it.

Loading voting…