Skip to content

← Actionable
Medium, CVSS 6.1

GeoServer has a Reflected Cross-Site Scripting (XSS) vulnerability in its WMS GetFeatureInfo HTML format

CVE-2025-21621GHSA-w66h-j855-qr72

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver.web:gs-web-app 2.25.0; org.geoserver:gs-wms 2.25.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2025-21621: 0.32% estimated exploitation activity in the next 30 days; percentile 24.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A reflected cross-site scripting (XSS) vulnerability exists in the WMS GetFeatureInfo HTML output format that enables a remote attacker to execute arbitrary JavaScript code in a victim's browser through specially crafted SLDBODY parameters. Details The WMS service setting that controls HTML auto-escaping is either disabled by default, or completely missing, in the affected versions (see workarounds). Impact If an attacker can control a script that is executed in the victim's browser, then they can typically fully compromise that user. Amongst other things, the attacker can: 1. Perform any action within the application that the user can perform. 2. View any information that the user is able to view. 3. Modify any information that the user is able to modify. 4. Initiate interactions with other application users, including malicious attacks, that will appear to originate from the initial victim user. Workarounds Changing any of the following WMS service settings should mitigate…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w66h-j855-qr72

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-21621

Advisory: GeoServer has a Reflected Cross-Site Scripting (XSS) vulnerability in its WMS GetFeatureInfo HTML format
IDs: CVE-2025-21621, GHSA-w66h-j855-qr72
Record: https://patchnext.com/advisories/cve-2025-21621 (revision 1, source checked 26 Oct 2026, 16:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.geoserver.web:gs-web-app 2.25.0; org.geoserver:gs-wms 2.25.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.geoserver.web:gs-web-app: affected < 2.25.0; fixed in 2.25.0
- Maven org.geoserver:gs-wms: affected < 2.25.0; fixed in 2.25.0

## Suggested inspection (read-only)
- Maven org.geoserver.web:gs-web-app: check the installed version with your package manager.
- Maven org.geoserver:gs-wms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.geoserver.web:gs-web-app, org.geoserver:gs-wms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w66h-j855-qr72 (GitHub-reviewed advisory GHSA-w66h-j855-qr72 lists affected ranges: Maven org.geoserver.web:gs-web-app >=0 =0 <2.25.0)

Commands are suggestions: review each one before running it.

Loading voting…