go-git clients vulnerable to DoS via maliciously crafted Git server replies
CVE-2025-21614GHSA-r9px-m959-cxf4
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/go-git/go-git/v5
- Affected
- < 5.13.0
- Fixed in
- 5.13.0
Go gopkg.in/src-d/go-git.v4
- Affected
- >= 4.0.0, <= 4.13.1
- Fixed in
- no fixed version recorded
Go github.com/go-git/go-git
- Affected
- >= 4.0.0, <= 4.13.1
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r9px-m959-cxf4 lists affected ranges: Go gopkg.in/src-d/go-git.v4 >=4.0.0 =0 =4.0.0 <=4.13.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-21614: 0.72% estimated exploitation activity in the next 30 days; percentile 53.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A denial of service (DoS) vulnerability was discovered in go-git versions prior to v5.13. This vulnerability allows an attacker to perform denial of service attacks by providing specially crafted responses from a Git server which triggers resource exhaustion in go-git clients. This is a go-git implementation issue and does not affect the upstream git cli. Patches Users running versions of go-git from v4 and above are recommended to upgrade to v5.13 in order to mitigate this vulnerability. Workarounds In cases where a bump to the latest version of go-git is not possible, we recommend limiting its use to only trust-worthy Git servers. Credit Thanks to Ionut Lalu for responsibly disclosing this vulnerability to us.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r9px-m959-cxf4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-21614 Advisory: go-git clients vulnerable to DoS via maliciously crafted Git server replies IDs: CVE-2025-21614, GHSA-r9px-m959-cxf4 Record: https://patchnext.com/advisories/cve-2025-21614 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/go-git/go-git/v5 5.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/go-git/go-git/v5: affected < 5.13.0; fixed in 5.13.0 - Go gopkg.in/src-d/go-git.v4: affected >= 4.0.0, <= 4.13.1 - Go github.com/go-git/go-git: affected >= 4.0.0, <= 4.13.1 ## Suggested inspection (read-only) - Go github.com/go-git/go-git/v5: check the installed version with your package manager. - Go gopkg.in/src-d/go-git.v4: check the installed version with your package manager. - Go github.com/go-git/go-git: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/go-git/go-git/v5, gopkg.in/src-d/go-git.v4, github.com/go-git/go-git. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r9px-m959-cxf4 (GitHub-reviewed advisory GHSA-r9px-m959-cxf4 lists affected ranges: Go gopkg.in/src-d/go-git.v4 >=4.0.0 =0 =4.0.0 <=4.13.1) Commands are suggestions: review each one before running it.
Loading voting…