Skip to content

← Actionable
High, CVSS 8.6

Extension:TabberNeue vulnerable to Cross-site Scripting

CVE-2025-21612GHSA-4x6x-8rm8-c37j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (starcitizentools/tabber-neue 2.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
EPSS
  • CVE-2025-21612: 0.50% estimated exploitation activity in the next 30 days; percentile 43.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary There are several sources of arbitrary, unescaped user input being used to construct HTML, which allows any user that can edit pages or otherwise render wikitext to XSS other users. Edit: Only the first XSS can be reproduced in production. Details ✅ Verified and patched in f229cab099c69006e25d4bad3579954e481dc566 https://github.com/StarCitizenTools/mediawiki-extensions-TabberNeue/blob/2526daa9f8cfdd616c861c8439755cb74a6c8c6e/includes/TabberTransclude.php#L154 This doesn't escape the user-supplied page name when outputting, so an XSS payload as the page name can be used here. This was caused by d8c3db4e5935476e496d979fb01f775d3d3282e6. ---- ❌ Invalid as MediaWiki parser sanitizes dangerous HTML https://github.com/StarCitizenTools/mediawiki-extensions-TabberNeue/blob/2526daa9f8cfdd616c861c8439755cb74a6c8c6e/includes/Tabber.php#L160 The documentation for Parser::recursiveTagParse() states that it returns unsafe HTML, and the $content being supplied is from user input. This was…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4x6x-8rm8-c37j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-21612

Advisory: Extension:TabberNeue vulnerable to Cross-site Scripting
IDs: CVE-2025-21612, GHSA-4x6x-8rm8-c37j
Record: https://patchnext.com/advisories/cve-2025-21612 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: starcitizentools/tabber-neue 2.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist starcitizentools/tabber-neue: affected >= 1.9.1, < 2.7.2; fixed in 2.7.2

## Suggested inspection (read-only)
- Packagist starcitizentools/tabber-neue: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on starcitizentools/tabber-neue.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4x6x-8rm8-c37j (GitHub-reviewed advisory GHSA-4x6x-8rm8-c37j lists affected ranges: Packagist starcitizentools/tabber-neue >=1.9.1 <2.7.2)

Commands are suggestions: review each one before running it.

Loading voting…