Skip to content

← Actionable
Medium, CVSS 5.3amended

Trix allows Cross-site Scripting via javascript: url in a link

CVE-2025-21610GHSA-j386-3444-qgwg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (trix 2.1.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm trix

    Affected
    < 2.1.12
    Fixed in
    2.1.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-21610: 0.42% estimated exploitation activity in the next 30 days; percentile 36.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Trix editor, versions prior to 2.1.11, is vulnerable to XSS when pasting malicious code in the link field. Impact An attacker could trick the user to copy&paste a malicious javascript: URL as a link that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. See https://gist.github.com/th4s1s/3921fd9c3e324ad9a3e0d846166e3eb8 Patches Update Recommendation: Users should upgrade to Trix editor version 2.1.12 or later. Workarounds This is not really a workaround but something that should be considered in addition to upgrading to the patched version. If affected users can disallow browsers that don't support a Content Security Policy, then this would be an effective workaround for this and all XSS vulnerabilities. Set CSP policies such as script-src 'self' to ensure that only scripts hosted on the same origin are executed, and explicitly prohibit inline…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-j386-3444-qgwg

  2. Revision 1 · created ·

    Published from osv record GHSA-j386-3444-qgwg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-21610

Advisory: Trix allows Cross-site Scripting via `javascript:` url in a link
IDs: CVE-2025-21610, GHSA-j386-3444-qgwg
Record: https://patchnext.com/advisories/cve-2025-21610 (revision 2, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: trix 2.1.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm trix: affected < 2.1.12; fixed in 2.1.12

## Suggested inspection (read-only)
- `npm ls trix --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on trix.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-j386-3444-qgwg (OSV record GHSA-j386-3444-qgwg lists affected ranges: npm trix >=0 <2.1.12 (fixed))
- Verified: https://github.com/advisories/GHSA-j386-3444-qgwg (GitHub-reviewed advisory GHSA-j386-3444-qgwg lists affected ranges: npm trix >=0 <2.1.12)

Commands are suggestions: review each one before running it.

Loading voting…