Skip to content

← Actionable
Medium, CVSS 6.5

Mattermost fails to properly validate post props

CVE-2025-20088GHSA-45v9-w9fh-33j6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 10.2.1, 10.1.4, 10.0.4, 9.11.6, 8.0.0-20241127161322-25ff7a3779a5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/mattermost/mattermost/server/v8

    Affected
    >= 10.2.0, < 10.2.1>= 10.1.0, <= 10.1.3>= 10.0.0, <= 10.0.3>= 9.11.0, <= 9.11.5< 8.0.0-20241127161322-25ff7a3779a5
    Fixed in
    10.0.4, 8.0.0-20241127161322-25ff7a3779a5, 10.1.4, 9.11.6, 10.2.1

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-45v9-w9fh-33j6 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.2.0 =10.1.0 =10.0.0 =9.11.0 =0 <8.0.0-20241127161322-25ff7a3779a5

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2025-20088: 0.58% estimated exploitation activity in the next 30 days; percentile 47.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 10.2.x <= 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly validate post props which allows a malicious authenticated user to cause a crash via a malicious post.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-45v9-w9fh-33j6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-20088

Advisory: Mattermost fails to properly validate post props
IDs: CVE-2025-20088, GHSA-45v9-w9fh-33j6
Record: https://patchnext.com/advisories/cve-2025-20088 (revision 1, source checked 26 Oct 2026, 15:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 10.2.1, 10.1.4, 10.0.4, 9.11.6, 8.0.0-20241127161322-25ff7a3779a5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost/server/v8: affected >= 10.2.0, < 10.2.1; >= 10.1.0, <= 10.1.3; >= 10.0.0, <= 10.0.3; >= 9.11.0, <= 9.11.5; < 8.0.0-20241127161322-25ff7a3779a5; fixed in 10.0.4, 8.0.0-20241127161322-25ff7a3779a5, 10.1.4, 9.11.6, 10.2.1

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost/server/v8.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-45v9-w9fh-33j6 (GitHub-reviewed advisory GHSA-45v9-w9fh-33j6 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.2.0 =10.1.0 =10.0.0 =9.11.0 =0 <8.0.0-20241127161322-25ff7a3779a5)

Commands are suggestions: review each one before running it.

Loading voting…