Skip to content

← Actionable
Medium, CVSS 4.3

Mattermost Improper Validation of Specified Type of Input vulnerability

CVE-2025-20033GHSA-2549-xh72-qrpm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 10.2.1, 10.1.4, 10.0.4, 9.11.16, 8.0.0-20250102081831-64c566a8280b), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/mattermost/mattermost/server/v8

    Affected
    >= 9.11.0, < 9.11.16>= 10.0.0, < 10.0.4>= 10.1.0, < 10.1.4>= 10.2.0, <= 10.2.0< 8.0.0-20250102081831-64c566a8280b
    Fixed in
    10.0.4, 10.1.4, 9.11.16, 8.0.0-20250102081831-64c566a8280b, 10.2.1

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-2549-xh72-qrpm lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=9.11.0 =10.0.0 =10.1.0 =10.2.0 =0 <8.0.0-20250102081831-64c566a8280b

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2025-20033: 0.61% estimated exploitation activity in the next 30 days; percentile 49.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly validate post types, which allows attackers to deny service to users with the sysconsolereadplugins permission via creating a post with the customplnotification type and specific props.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2549-xh72-qrpm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-20033

Advisory: Mattermost Improper Validation of Specified Type of Input vulnerability
IDs: CVE-2025-20033, GHSA-2549-xh72-qrpm
Record: https://patchnext.com/advisories/cve-2025-20033 (revision 1, source checked 26 Oct 2026, 15:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 10.2.1, 10.1.4, 10.0.4, 9.11.16, 8.0.0-20250102081831-64c566a8280b. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost/server/v8: affected >= 9.11.0, < 9.11.16; >= 10.0.0, < 10.0.4; >= 10.1.0, < 10.1.4; >= 10.2.0, <= 10.2.0; < 8.0.0-20250102081831-64c566a8280b; fixed in 10.0.4, 10.1.4, 9.11.16, 8.0.0-20250102081831-64c566a8280b, 10.2.1

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost/server/v8.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2549-xh72-qrpm (GitHub-reviewed advisory GHSA-2549-xh72-qrpm lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=9.11.0 =10.0.0 =10.1.0 =10.2.0 =0 <8.0.0-20250102081831-64c566a8280b)

Commands are suggestions: review each one before running it.

Loading voting…