Qiskit allows arbitrary code execution decoding QPY format versions < 13
CVE-2025-2000GHSA-6m2c-76ff-6vrf
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI qiskit
- Affected
- <= 1.4.1>= 2.0.0rc1, <= 2.0.0rc1
- Fixed in
- 1.4.2, 2.0.0rc2
PyPI qiskit-terra
- Affected
- >= 0.18.0, <= 0.46.3
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6m2c-76ff-6vrf lists affected ranges: PyPI qiskit-terra >=0.18.0 =0 =2.0.0rc1 <2.0.0rc2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6m2c-76ff-6vrf lists affected ranges: PyPI qiskit-terra >=0.18.0 =0 =2.0.0rc1 <=2.0.0rc1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-2000: 0.81% estimated exploitation activity in the next 30 days; percentile 56.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A maliciously crafted QPY file can potentially execute arbitrary-code embedded in the payload without privilege escalation when deserializing QPY formats < 13. A python process calling Qiskit's qiskit.qpy.load() function could potentially execute any arbitrary Python code embedded in the correct place in the binary file as part of a specially constructed payload. Patches Fixed in Qiskit 1.4.2 and in Qiskit 2.0.0rc2
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6m2c-76ff-6vrf
- Revision 2 · amended ·
Amended from ghsa record GHSA-6m2c-76ff-6vrf
- Revision 1 · created ·
Published from osv record GHSA-6m2c-76ff-6vrf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-2000 Advisory: Qiskit allows arbitrary code execution decoding QPY format versions < 13 IDs: CVE-2025-2000, GHSA-6m2c-76ff-6vrf Record: https://patchnext.com/advisories/cve-2025-2000 (revision 3, source checked 4 Nov 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: qiskit 2.0.0rc2, 1.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI qiskit: affected <= 1.4.1; >= 2.0.0rc1, <= 2.0.0rc1; fixed in 1.4.2, 2.0.0rc2 - PyPI qiskit-terra: affected >= 0.18.0, <= 0.46.3 ## Suggested inspection (read-only) - `python -m pip show qiskit`: prints the installed version. Run with the environment that serves production active. - `python -m pip show qiskit-terra`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on qiskit, qiskit-terra. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6m2c-76ff-6vrf (OSV record GHSA-6m2c-76ff-6vrf lists affected ranges: PyPI qiskit-terra >=0.18.0 =0 =2.0.0rc1 <2.0.0rc2 (fixed)) - Verified: https://github.com/advisories/GHSA-6m2c-76ff-6vrf (GitHub-reviewed advisory GHSA-6m2c-76ff-6vrf lists affected ranges: PyPI qiskit-terra >=0.18.0 =0 =2.0.0rc1 <=2.0.0rc1) Commands are suggestions: review each one before running it.
Loading voting…