ray vulnerable to Insertion of Sensitive Information into Log File
CVE-2025-1979GHSA-w4rh-fgx7-q63m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ray 2.43.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ray
- Affected
- < 2.43.0
- Fixed in
- 2.43.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w4rh-fgx7-q63m lists affected ranges: PyPI ray >=0 <2.43.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w4rh-fgx7-q63m lists affected ranges: PyPI ray >=0 <2.43.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.7 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2025-1979: 0.20% estimated exploitation activity in the next 30 days; percentile 9.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of the package ray before 2.43.0 are vulnerable to Insertion of Sensitive Information into Log File where the redis password is being logged in the standard logging. If the redis password is passed as an argument, it will be logged and could potentially leak the password. This is only exploitable if: 1) Logging is enabled; 2) Redis is using password authentication; 3) Those logs are accessible to an attacker, who can reach that redis instance. Note: It is recommended that anyone who is running in this configuration should update to the latest version of Ray, then rotate their redis password.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w4rh-fgx7-q63m
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-w4rh-fgx7-q63m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-1979 Advisory: ray vulnerable to Insertion of Sensitive Information into Log File IDs: CVE-2025-1979, GHSA-w4rh-fgx7-q63m Record: https://patchnext.com/advisories/cve-2025-1979 (revision 3, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ray 2.43.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ray: affected < 2.43.0; fixed in 2.43.0 ## Suggested inspection (read-only) - `python -m pip show ray`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ray. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w4rh-fgx7-q63m (OSV record GHSA-w4rh-fgx7-q63m lists affected ranges: PyPI ray >=0 <2.43.0 (fixed)) - Verified: https://github.com/advisories/GHSA-w4rh-fgx7-q63m (GitHub-reviewed advisory GHSA-w4rh-fgx7-q63m lists affected ranges: PyPI ray >=0 <2.43.0) Commands are suggestions: review each one before running it.
Loading voting…