Skip to content

← Actionable
High, CVSS 7.8amended

LLama-Index CLI OS command injection vulnerability

CVE-2025-1753GHSA-g99h-56mw-8263

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI llama-index-cli

    Affected
    < 0.4.1
    Fixed in
    0.4.1
  • PyPI llama-index

    Affected
    <= 0.12.20
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-1753: 1.14% estimated exploitation activity in the next 30 days; percentile 66.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

LLama-Index CLI prior to v0.4.1, corresponding to LLama-Index prior to v0.12.21, contains an OS command injection vulnerability. The vulnerability arises from the improper handling of the --files argument, which is directly passed into os.system. An attacker who controls the content of this argument can inject and execute arbitrary shell commands. This vulnerability can be exploited locally if the attacker has control over the CLI arguments, and remotely if a web application calls the LLama-Index CLI with a user-controlled filename. This issue can lead to arbitrary code execution on the affected system.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-g99h-56mw-8263

  2. Revision 2 · amended ·

    Amended from osv record PYSEC-2025-246

  3. Revision 1 · created ·

    Published from osv record GHSA-g99h-56mw-8263

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-1753

Advisory: LLama-Index CLI OS command injection vulnerability
IDs: CVE-2025-1753, GHSA-g99h-56mw-8263
Record: https://patchnext.com/advisories/cve-2025-1753 (revision 3, source checked 26 Oct 2026, 13:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: llama-index-cli 0.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI llama-index-cli: affected < 0.4.1; fixed in 0.4.1
- PyPI llama-index: affected <= 0.12.20

## Suggested inspection (read-only)
- `python -m pip show llama-index-cli`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show llama-index`: prints the installed version. Run with the environment that serves production active.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on llama-index-cli, llama-index.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g99h-56mw-8263 (OSV record GHSA-g99h-56mw-8263 lists affected ranges: PyPI llama-index-cli >=0 <0.4.1 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2025-246 (OSV record PYSEC-2025-246 lists affected ranges: PyPI llama-index >=0 <=0.12.20)
- Verified: https://github.com/advisories/GHSA-g99h-56mw-8263 (GitHub-reviewed advisory GHSA-g99h-56mw-8263 lists affected ranges: PyPI llama-index-cli >=0 <0.4.1)

Commands are suggestions: review each one before running it.

Loading voting…