LlamaIndex Vulnerable to Denial of Service (DoS)
CVE-2025-1752GHSA-7c85-87cp-mr6g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (llama-index 0.12.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI llama-index
- Affected
- >= 0.12.15, < 0.12.21
- Fixed in
- 0.12.21
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7c85-87cp-mr6g lists affected ranges: PyPI llama-index >=0.12.15 <0.12.21 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7c85-87cp-mr6g lists affected ranges: PyPI llama-index >=0.12.15 <0.12.21
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-1752: 0.52% estimated exploitation activity in the next 30 days; percentile 44.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Denial of Service (DoS) vulnerability has been identified in the KnowledgeBaseWebReader class of the run-llama/llamaindex project, affecting version ~ latest(v0.12.15). The vulnerability arises due to inappropriate secure coding measures, specifically the lack of proper implementation of the maxdepth parameter in the getarticleurls function. This allows an attacker to exhaust Python's recursion limit through repeated function calls, leading to resource consumption and ultimately crashing the Python process.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7c85-87cp-mr6g
- Revision 1 · created ·
Published from osv record GHSA-7c85-87cp-mr6g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-1752 Advisory: LlamaIndex Vulnerable to Denial of Service (DoS) IDs: CVE-2025-1752, GHSA-7c85-87cp-mr6g Record: https://patchnext.com/advisories/cve-2025-1752 (revision 2, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: llama-index 0.12.21. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI llama-index: affected >= 0.12.15, < 0.12.21; fixed in 0.12.21 ## Suggested inspection (read-only) - `python -m pip show llama-index`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on llama-index. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7c85-87cp-mr6g (OSV record GHSA-7c85-87cp-mr6g lists affected ranges: PyPI llama-index >=0.12.15 <0.12.21 (fixed)) - Verified: https://github.com/advisories/GHSA-7c85-87cp-mr6g (GitHub-reviewed advisory GHSA-7c85-87cp-mr6g lists affected ranges: PyPI llama-index >=0.12.15 <0.12.21) Commands are suggestions: review each one before running it.
Loading voting…