MongoDB Shell may be susceptible to Control Character Injection via autocomplete
CVE-2025-1691GHSA-43g5-2wr2-q7vj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mongosh 2.3.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mongosh
- Affected
- < 2.3.9
- Fixed in
- 2.3.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-43g5-2wr2-q7vj lists affected ranges: npm mongosh >=0 <2.3.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-43g5-2wr2-q7vj lists affected ranges: npm mongosh >=0 <2.3.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2025-1691: 0.36% estimated exploitation activity in the next 30 days; percentile 29.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The MongoDB Shell may be susceptible to control character injection where an attacker with control of the mongosh autocomplete feature, can use the autocompletion feature to input and run obfuscated malicious text. This requires user interaction in the form of the user using ‘tab’ to autocomplete text that is a prefix of the attacker’s prepared autocompletion. This issue affects mongosh versions prior to 2.3.9. The vulnerability is exploitable only when mongosh is connected to a cluster that is partially or fully controlled by an attacker.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-43g5-2wr2-q7vj
- Revision 1 · created ·
Published from osv record GHSA-43g5-2wr2-q7vj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-1691 Advisory: MongoDB Shell may be susceptible to Control Character Injection via autocomplete IDs: CVE-2025-1691, GHSA-43g5-2wr2-q7vj Record: https://patchnext.com/advisories/cve-2025-1691 (revision 2, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mongosh 2.3.9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mongosh: affected < 2.3.9; fixed in 2.3.9 ## Suggested inspection (read-only) - `npm ls mongosh --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mongosh. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-43g5-2wr2-q7vj (OSV record GHSA-43g5-2wr2-q7vj lists affected ranges: npm mongosh >=0 <2.3.9 (fixed)) - Verified: https://github.com/advisories/GHSA-43g5-2wr2-q7vj (GitHub-reviewed advisory GHSA-43g5-2wr2-q7vj lists affected ranges: npm mongosh >=0 <2.3.9) Commands are suggestions: review each one before running it.
Loading voting…