DOMPurify contains a Cross-site Scripting vulnerability
CVE-2025-15599GHSA-v8jm-5vwx-cfxm
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm dompurify
- Affected
- >= 3.1.3, < 3.2.7>= 2.5.3, <= 2.5.8
- Fixed in
- 3.2.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v8jm-5vwx-cfxm lists affected ranges: npm dompurify >=3.1.3 =2.5.3 <=2.5.8
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v8jm-5vwx-cfxm lists affected ranges: npm dompurify >=3.1.3 =2.5.3 <=2.5.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2025-15599: 0.29% estimated exploitation activity in the next 30 days; percentile 21.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
DOMPurify 3.1.3 through 3.2.6 and 2.5.3 through 2.5.8 contain a cross-site scripting vulnerability that allows attackers to bypass attribute sanitization by exploiting missing textarea rawtext element validation in the SAFEFORXML regex. Attackers can include closing rawtext tags like </textarea in attribute values to break out of rawtext contexts and execute JavaScript when sanitized output is placed inside rawtext elements. The 3.x branch was fixed in 3.2.7; the 2.x branch was never patched.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v8jm-5vwx-cfxm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-v8jm-5vwx-cfxm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-15599 Advisory: DOMPurify contains a Cross-site Scripting vulnerability IDs: CVE-2025-15599, GHSA-v8jm-5vwx-cfxm Record: https://patchnext.com/advisories/cve-2025-15599 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: dompurify 3.2.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm dompurify: affected >= 3.1.3, < 3.2.7; >= 2.5.3, <= 2.5.8; fixed in 3.2.7 ## Suggested inspection (read-only) - `npm ls dompurify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dompurify. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v8jm-5vwx-cfxm (OSV record GHSA-v8jm-5vwx-cfxm lists affected ranges: npm dompurify >=3.1.3 =2.5.3 <=2.5.8) - Verified: https://github.com/advisories/GHSA-v8jm-5vwx-cfxm (GitHub-reviewed advisory GHSA-v8jm-5vwx-cfxm lists affected ranges: npm dompurify >=3.1.3 =2.5.3 <=2.5.8) Commands are suggestions: review each one before running it.
Loading voting…