Skip to content

← Actionable
Low, CVSS 1.9amended

LIEF is vulnerable to segmentation fault

CVE-2025-15504GHSA-mjjp-xjfg-97wg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lief 0.17.2; lief 0.17.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI lief

    Affected
    < 0.17.2
    Fixed in
    0.17.2
  • crates.io lief

    Affected
    < 0.17.2
    Fixed in
    0.17.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-15504: 0.27% estimated exploitation activity in the next 30 days; percentile 18.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A security flaw has been discovered in lief-project LIEF up to 0.17.1. Affected by this issue is the function Parser::parsebinary of the file src/ELF/Parser.tcc of the component ELF Binary Parser. The manipulation results in null pointer dereference. The attack must be initiated from a local position. The exploit has been released to the public and may be used for attacks. Upgrading to version 0.17.2 can resolve this issue. The patch is identified as 81bd5d7ea0c390563f1c4c017c9019d154802978. It is recommended to upgrade the affected component.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mjjp-xjfg-97wg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-mjjp-xjfg-97wg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-15504

Advisory: LIEF is vulnerable to segmentation fault
IDs: CVE-2025-15504, GHSA-mjjp-xjfg-97wg
Record: https://patchnext.com/advisories/cve-2025-15504 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lief 0.17.2; lief 0.17.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI lief: affected < 0.17.2; fixed in 0.17.2
- crates.io lief: affected < 0.17.2; fixed in 0.17.2

## Suggested inspection (read-only)
- `python -m pip show lief`: prints the installed version. Run with the environment that serves production active.
- crates.io lief: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lief.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mjjp-xjfg-97wg (OSV record GHSA-mjjp-xjfg-97wg lists affected ranges: PyPI lief >=0 =0 <0.17.2 (fixed))
- Verified: https://github.com/advisories/GHSA-mjjp-xjfg-97wg (GitHub-reviewed advisory GHSA-mjjp-xjfg-97wg lists affected ranges: PyPI lief >=0 =0 <0.17.2)

Commands are suggestions: review each one before running it.

Loading voting…