Skip to content

← Actionable
High, CVSS 7.3amended

Arbitrary Code Execution via Crafted Keras Config for Model Loading

CVE-2025-1550GHSA-48g7-3x6r-xfhp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (keras 3.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI keras

    Affected
    >= 3.0.0, < 3.9.0
    Fixed in
    3.9.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-1550: 2.63% estimated exploitation activity in the next 30 days; percentile 85.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Keras Model.loadmodel function permits arbitrary code execution, even with safemode=True, through a manually constructed, malicious .keras archive. By altering the config.json file within the archive, an attacker can specify arbitrary Python modules and functions, along with their arguments, to be loaded and executed during model loading. Patches This problem is fixed starting with version 3.9. Workarounds Only load models from trusted sources and model archives created with Keras. References - https://www.cve.org/cverecord?id=CVE-2025-1550 - https://github.com/keras-team/keras/pull/20751

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-48g7-3x6r-xfhp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-48g7-3x6r-xfhp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-1550

Advisory: Arbitrary Code Execution via Crafted Keras Config for Model Loading
IDs: CVE-2025-1550, GHSA-48g7-3x6r-xfhp
Record: https://patchnext.com/advisories/cve-2025-1550 (revision 3, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: keras 3.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI keras: affected >= 3.0.0, < 3.9.0; fixed in 3.9.0

## Suggested inspection (read-only)
- `python -m pip show keras`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on keras.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-48g7-3x6r-xfhp (OSV record GHSA-48g7-3x6r-xfhp lists affected ranges: PyPI keras >=3.0.0 <3.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-48g7-3x6r-xfhp (GitHub-reviewed advisory GHSA-48g7-3x6r-xfhp lists affected ranges: PyPI keras >=3.0.0 <3.9.0)

Commands are suggestions: review each one before running it.

Loading voting…