MLflow Command Injection vulnerability
CVE-2025-15379GHSA-r23q-823p-vmf7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mlflow 3.8.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mlflow
- Affected
- < 3.8.1
- Fixed in
- 3.8.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r23q-823p-vmf7 lists affected ranges: PyPI mlflow >=0 <3.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r23q-823p-vmf7 lists affected ranges: PyPI mlflow >=0 <3.8.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2025-15379: 2.40% estimated exploitation activity in the next 30 days; percentile 84.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A command injection vulnerability exists in MLflow's model serving container initialization code, specifically in the installmodeldependenciestoenv() function. When deploying a model with envmanager=LOCAL, MLflow reads dependency specifications from the model artifact's pythonenv.yaml file and directly interpolates them into a shell command without sanitization. This allows an attacker to supply a malicious model artifact and achieve arbitrary command execution on systems that deploy the model. The vulnerability affects versions 3.8.0 and is fixed in version 3.8.1.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-r23q-823p-vmf7
- Revision 2 · amended ·
Amended from osv record GHSA-r23q-823p-vmf7
- Revision 1 · created ·
Published from ghsa record GHSA-r23q-823p-vmf7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-15379 Advisory: MLflow Command Injection vulnerability IDs: CVE-2025-15379, GHSA-r23q-823p-vmf7 Record: https://patchnext.com/advisories/cve-2025-15379 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mlflow 3.8.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mlflow: affected < 3.8.1; fixed in 3.8.1 ## Suggested inspection (read-only) - `python -m pip show mlflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mlflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r23q-823p-vmf7 (GitHub-reviewed advisory GHSA-r23q-823p-vmf7 lists affected ranges: PyPI mlflow >=0 <3.8.1) - Verified: https://osv.dev/vulnerability/GHSA-r23q-823p-vmf7 (OSV record GHSA-r23q-823p-vmf7 lists affected ranges: PyPI mlflow >=0 <3.8.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…