wolfSSL Python module vulnerable to Improper Authentication
CVE-2025-15346GHSA-vj87-jj27-4h9c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wolfssl 5.8.4.post0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI wolfssl
- Affected
- < 5.8.4.post0
- Fixed in
- 5.8.4.post0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vj87-jj27-4h9c lists affected ranges: PyPI wolfssl >=0 <5.8.4.post0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vj87-jj27-4h9c lists affected ranges: PyPI wolfssl >=0 <5.8.4.post0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-15346: 0.33% estimated exploitation activity in the next 30 days; percentile 26.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability in the handling of verifymode = CERTREQUIRED in the wolfssl Python package (wolfssl-py) causes client certificate requirements to not be fully enforced. Because the WOLFSSLVERIFYFAILIFNOPEERCERT flag was not included, the behavior effectively matched CERTOPTIONAL: a peer certificate was verified if presented, but connections were incorrectly authenticated when no client certificate was provided. This results in improper authentication, allowing attackers to bypass mutual TLS (mTLS) client authentication by omitting a client certificate during the TLS handshake. The issue affects versions up to and including 5.8.2.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vj87-jj27-4h9c
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vj87-jj27-4h9c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-15346 Advisory: wolfSSL Python module vulnerable to Improper Authentication IDs: CVE-2025-15346, GHSA-vj87-jj27-4h9c Record: https://patchnext.com/advisories/cve-2025-15346 (revision 3, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wolfssl 5.8.4.post0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI wolfssl: affected < 5.8.4.post0; fixed in 5.8.4.post0 ## Suggested inspection (read-only) - `python -m pip show wolfssl`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wolfssl. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vj87-jj27-4h9c (OSV record GHSA-vj87-jj27-4h9c lists affected ranges: PyPI wolfssl >=0 <5.8.4.post0 (fixed)) - Verified: https://github.com/advisories/GHSA-vj87-jj27-4h9c (GitHub-reviewed advisory GHSA-vj87-jj27-4h9c lists affected ranges: PyPI wolfssl >=0 <5.8.4.post0) Commands are suggestions: review each one before running it.
Loading voting…