Skip to content

← Actionable
High, CVSS 7.5amended

figma-developer-mcp vulnerable to command injection in get_figma_data tool

CVE-2025-15061GHSA-gxw4-4fc5-9gr5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (figma-developer-mcp 0.6.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-15061: 2.18% estimated exploitation activity in the next 30 days; percentile 82.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
  • CVE-2025-53967: 6.12% estimated exploitation activity in the next 30 days; percentile 93.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A command injection vulnerability exists in the figma-developer-mcp MCP Server. The vulnerability is caused by the unsanitized use of input parameters within a call to childprocess.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, , &&, etc.). Details The MCP Server exposes tools to perform several figma operations. An MCP Client can be instructed to execute additional actions for example via indirect prompt injection that can lead to command injection by calling vulnerable tools with malicious inputs. Below some example of vulnerable code and different ways to test this vulnerability. Vulnerable code The following snippet illustrates the vulnerable code pattern used in the MCP…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-gxw4-4fc5-9gr5

  2. Revision 1 · created ·

    Published from osv record GHSA-gxw4-4fc5-9gr5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-15061

Advisory: figma-developer-mcp vulnerable to command injection in get_figma_data tool
IDs: CVE-2025-15061, GHSA-gxw4-4fc5-9gr5
Record: https://patchnext.com/advisories/cve-2025-15061 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: figma-developer-mcp 0.6.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm figma-developer-mcp: affected <= 0.6.2; fixed in 0.6.3

## Suggested inspection (read-only)
- `npm ls figma-developer-mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on figma-developer-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gxw4-4fc5-9gr5 (OSV record GHSA-gxw4-4fc5-9gr5 lists affected ranges: npm figma-developer-mcp >=0 <0.6.3 (fixed))
- Verified: https://github.com/advisories/GHSA-gxw4-4fc5-9gr5 (GitHub-reviewed advisory GHSA-gxw4-4fc5-9gr5 lists affected ranges: npm figma-developer-mcp >=0 <=0.6.2)

Commands are suggestions: review each one before running it.

Loading voting…