Skip to content

← Actionable
Medium, CVSS 4.8

Vaadin vulnerable to Cross-site Scripting

CVE-2025-15022GHSA-7wwv-79xw-rvvg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.vaadin:vaadin-server 8.30.0, 7.7.50; com.vaadin:vaadin 24.9.7, 24.8.14, 23.6.6; com.vaadin:vaadin-spreadsheet-flow 24.9.7, 24.8.14, 23.6.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-7wwv-79xw-rvvg lists affected ranges: Maven com.vaadin:vaadin-server >=7.0.0 =8.0.0 =23.1.0 =24.0.0 =24.9.0 =23.1.0 =24.0.0 =24.9.0 <24.9.7

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2025-15022: 0.33% estimated exploitation activity in the next 30 days; percentile 26.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Action captions in Vaadin accept HTML by default but were not sanitized, potentially allowing Cross-site Scripting (XSS) if caption content is derived from user input. In Vaadin Framework 7 and 8, the Action class is a general-purpose class that may be used by multiple components. The fixed versions sanitize captions by default and provide an API to explicitly enable HTML content mode for backwards compatibility. In Vaadin 23 and newer, the Action class is only used by the Spreadsheet component. The fixed versions sanitize HTML using Jsoup with a relaxed safelist. Vaadin 14 is not affected as Spreadsheet component was not supported. Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include: Product version Vaadin 7.0.0 - 7.7.49 Vaadin 8.0.0 - 8.29.1 Vaadin 23.1.0 - 23.6.5 Vaadin 24.0.0 - 24.8.13 Vaadin 24.9.0 - 24.9.6 Mitigation Upgrade to 7.7.50 Upgrade to 8.30.0 Upgrade to 23.6.6 Upgrade to 24.8.14 or 24.9.7 Upgrade to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7wwv-79xw-rvvg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-15022

Advisory: Vaadin vulnerable to Cross-site Scripting
IDs: CVE-2025-15022, GHSA-7wwv-79xw-rvvg
Record: https://patchnext.com/advisories/cve-2025-15022 (revision 1, source checked 26 Oct 2026, 16:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.vaadin:vaadin-server 8.30.0, 7.7.50; com.vaadin:vaadin 24.9.7, 24.8.14, 23.6.6; com.vaadin:vaadin-spreadsheet-flow 24.9.7, 24.8.14, 23.6.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.vaadin:vaadin-server: affected >= 7.0.0, < 7.7.50; >= 8.0.0, < 8.30.0; fixed in 8.30.0, 7.7.50
- Maven com.vaadin:vaadin: affected >= 23.1.0, < 23.6.6; >= 24.0.0, < 24.8.14; >= 24.9.0, < 24.9.7; fixed in 23.6.6, 24.8.14, 24.9.7
- Maven com.vaadin:vaadin-spreadsheet-flow: affected >= 23.1.0, < 23.6.6; >= 24.0.0, < 24.8.14; >= 24.9.0, < 24.9.7; fixed in 23.6.6, 24.8.14, 24.9.7

## Suggested inspection (read-only)
- Maven com.vaadin:vaadin-server: check the installed version with your package manager.
- Maven com.vaadin:vaadin: check the installed version with your package manager.
- Maven com.vaadin:vaadin-spreadsheet-flow: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.vaadin:vaadin-server, com.vaadin:vaadin, com.vaadin:vaadin-spreadsheet-flow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7wwv-79xw-rvvg (GitHub-reviewed advisory GHSA-7wwv-79xw-rvvg lists affected ranges: Maven com.vaadin:vaadin-server >=7.0.0 =8.0.0 =23.1.0 =24.0.0 =24.9.0 =23.1.0 =24.0.0 =24.9.0 <24.9.7)

Commands are suggestions: review each one before running it.

Loading voting…