Skip to content

← Actionable
Low, CVSS 1.3

Temporal has a namespace policy bypass allowing requests to be authorized for incorrect contexts

CVE-2025-14986GHSA-p2gr-hm8g-q772

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (go.temporal.io/server 1.29.2, 1.28.2, 1.27.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go go.temporal.io/server

    Affected
    >= 1.24.0, < 1.27.4>= 1.28.0, < 1.28.2>= 1.29.0, < 1.29.2
    Fixed in
    1.29.2, 1.27.4, 1.28.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2025-14986: 0.43% estimated exploitation activity in the next 30 days; percentile 36.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When frontend.enableExecuteMultiOperation is enabled, the server can apply namespace-scoped validation and feature gates for the embedded StartWorkflowExecutionRequest using its Namespace field rather than the outer, authorized ExecuteMultiOperationRequest.Namespace. This allows a caller authorized for one namespace to bypass that namespace's limits/policies by setting the embedded start request's namespace to a different namespace. The workflow is still created in the outer (authorized) namespace; only validation/gating is performed under the wrong namespace context. This issue affects Temporal: from 1.24.0 through 1.29.1. Fixed in 1.27.4, 1.28.2, 1.29.2.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p2gr-hm8g-q772

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-14986

Advisory: Temporal has a namespace policy bypass allowing requests to be authorized for incorrect contexts
IDs: CVE-2025-14986, GHSA-p2gr-hm8g-q772
Record: https://patchnext.com/advisories/cve-2025-14986 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: go.temporal.io/server 1.29.2, 1.28.2, 1.27.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go go.temporal.io/server: affected >= 1.24.0, < 1.27.4; >= 1.28.0, < 1.28.2; >= 1.29.0, < 1.29.2; fixed in 1.29.2, 1.27.4, 1.28.2

## Suggested inspection (read-only)
- Go go.temporal.io/server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on go.temporal.io/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p2gr-hm8g-q772 (GitHub-reviewed advisory GHSA-p2gr-hm8g-q772 lists affected ranges: Go go.temporal.io/server >=1.24.0 =1.28.0 =1.29.0 <1.29.2)

Commands are suggestions: review each one before running it.

Loading voting…