Skip to content

← Actionable
Critical, CVSS 9.3amended

PlotAI eval vulnerability

CVE-2025-1497GHSA-2hmp-5wqg-f24h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (plotai 0.0.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI plotai

    Affected
    < 0.0.7
    Fixed in
    0.0.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-1497: 1.05% estimated exploitation activity in the next 30 days; percentile 64.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability, that could result in Remote Code Execution (RCE), has been found in PlotAI. Lack of validation of LLM-generated output allows attacker to execute arbitrary Python code. PlotAI commented out vulnerable line, further usage of the software requires uncommenting it and thus accepting the risk.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-2hmp-5wqg-f24h

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-2hmp-5wqg-f24h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-1497

Advisory: PlotAI eval vulnerability
IDs: CVE-2025-1497, GHSA-2hmp-5wqg-f24h
Record: https://patchnext.com/advisories/cve-2025-1497 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: plotai 0.0.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI plotai: affected < 0.0.7; fixed in 0.0.7

## Suggested inspection (read-only)
- `python -m pip show plotai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on plotai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2hmp-5wqg-f24h (OSV record GHSA-2hmp-5wqg-f24h lists affected ranges: PyPI plotai >=0 <0.0.7 (fixed))
- Verified: https://github.com/advisories/GHSA-2hmp-5wqg-f24h (GitHub-reviewed advisory GHSA-2hmp-5wqg-f24h lists affected ranges: PyPI plotai >=0 <0.0.7)

Commands are suggestions: review each one before running it.

Loading voting…