pretix has Broken Access Control Allowing Cross-User File Access via UUID
CVE-2025-14882GHSA-pmjj-h5jm-vxh4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pretix 2025.10.1, 2025.9.3, 2025.8.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pretix
- Affected
- >= 2025.10.0, < 2025.10.1>= 2025.9.0, < 2025.9.3< 2025.8.3
- Fixed in
- 2025.9.3, 2025.10.1, 2025.8.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pmjj-h5jm-vxh4 lists affected ranges: PyPI pretix >=2025.10.0 =2025.9.0 =0 <2025.8.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pmjj-h5jm-vxh4 lists affected ranges: PyPI pretix >=2025.10.0 =2025.9.0 =0 <2025.8.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 3.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-14882: 0.25% estimated exploitation activity in the next 30 days; percentile 16.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An API endpoint allowed access to sensitive files from other users by knowing the UUID of the file that were not intended to be accessible by UUID only.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pmjj-h5jm-vxh4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pmjj-h5jm-vxh4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-14882 Advisory: pretix has Broken Access Control Allowing Cross-User File Access via UUID IDs: CVE-2025-14882, GHSA-pmjj-h5jm-vxh4 Record: https://patchnext.com/advisories/cve-2025-14882 (revision 3, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pretix 2025.10.1, 2025.9.3, 2025.8.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pretix: affected >= 2025.10.0, < 2025.10.1; >= 2025.9.0, < 2025.9.3; < 2025.8.3; fixed in 2025.9.3, 2025.10.1, 2025.8.3 ## Suggested inspection (read-only) - `python -m pip show pretix`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pretix. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pmjj-h5jm-vxh4 (OSV record GHSA-pmjj-h5jm-vxh4 lists affected ranges: PyPI pretix >=2025.10.0 =2025.9.0 =0 <2025.8.3 (fixed)) - Verified: https://github.com/advisories/GHSA-pmjj-h5jm-vxh4 (GitHub-reviewed advisory GHSA-pmjj-h5jm-vxh4 lists affected ranges: PyPI pretix >=2025.10.0 =2025.9.0 =0 <2025.8.3) Commands are suggestions: review each one before running it.
Loading voting…