Skip to content

← Actionable
Medium, CVSS 5.4amended

FastAPI SSP is vulnerable to Cross-site Request Forgery (CSRF) through improper OAuth parameter validation

CVE-2025-14546GHSA-hp6r-r9vc-q8wx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastapi-sso 0.19.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2025-14546: 0.36% estimated exploitation activity in the next 30 days; percentile 29.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of the package fastapi-sso before 0.19.0 are vulnerable to Cross-site Request Forgery (CSRF) due to the improper validation of the OAuth state parameter during the authentication callback. While the getloginurl method allows for state generation, it does not persist the state or bind it to the user's session. Consequently, the verifyandprocess method accepts the state received in the query parameters without verifying it against a trusted local value. This allows a remote attacker to trick a victim into visiting a malicious callback URL, which can result in the attacker's account being linked to the victim's internal account.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hp6r-r9vc-q8wx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hp6r-r9vc-q8wx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-14546

Advisory: FastAPI SSP is vulnerable to Cross-site Request Forgery (CSRF) through improper OAuth parameter validation
IDs: CVE-2025-14546, GHSA-hp6r-r9vc-q8wx
Record: https://patchnext.com/advisories/cve-2025-14546 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fastapi-sso 0.19.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI fastapi-sso: affected < 0.19.0; fixed in 0.19.0

## Suggested inspection (read-only)
- `python -m pip show fastapi-sso`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fastapi-sso.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hp6r-r9vc-q8wx (OSV record GHSA-hp6r-r9vc-q8wx lists affected ranges: PyPI fastapi-sso >=0 <0.19.0 (fixed))
- Verified: https://github.com/advisories/GHSA-hp6r-r9vc-q8wx (GitHub-reviewed advisory GHSA-hp6r-r9vc-q8wx lists affected ranges: PyPI fastapi-sso >=0 <0.19.0)

Commands are suggestions: review each one before running it.

Loading voting…