Skip to content

← Actionable
Medium, CVSS 6.8

Mattermost is vulnerable to DoS due to infinite re-renders on API errors

CVE-2025-14435GHSA-mx8m-v8qm-xwr8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost-server 11.1.2, 11.0.7, 10.11.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:N/A:H
EPSS
  • CVE-2025-14435: 0.31% estimated exploitation activity in the next 30 days; percentile 23.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 10.11.x <= 10.11.8, 11.1.x <= 11.1.1, 11.0.x <= 11.0.6 fail to prevent infinite re-renders on API errors which allows authenticated users to cause application-level DoS via triggering unbounded component re-render loops.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mx8m-v8qm-xwr8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-14435

Advisory: Mattermost is vulnerable to DoS due to infinite re-renders on API errors
IDs: CVE-2025-14435, GHSA-mx8m-v8qm-xwr8
Record: https://patchnext.com/advisories/cve-2025-14435 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost-server 11.1.2, 11.0.7, 10.11.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost-server: affected >= 10.11.0, <= 10.11.8; >= 11.1.0, <= 11.1.1; >= 11.0.0, <= 11.0.6; fixed in 11.1.2, 10.11.9, 11.0.7

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mx8m-v8qm-xwr8 (GitHub-reviewed advisory GHSA-mx8m-v8qm-xwr8 lists affected ranges: Go github.com/mattermost/mattermost-server >=10.11.0 =11.1.0 =11.0.0 <=11.0.6)

Commands are suggestions: review each one before running it.

Loading voting…