MLFlow is vulnerable to DNS rebinding attacks due to a lack of Origin header validation
CVE-2025-14279GHSA-pgqp-8h46-6x4j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mlflow 3.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mlflow
- Affected
- < 3.5.0
- Fixed in
- 3.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pgqp-8h46-6x4j lists affected ranges: PyPI mlflow >=0 <3.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pgqp-8h46-6x4j lists affected ranges: PyPI mlflow >=0 <3.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2025-14279: 0.22% estimated exploitation activity in the next 30 days; percentile 12.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
MLFlow versions up to and including 3.4.0 are vulnerable to DNS rebinding attacks due to a lack of Origin header validation in the MLFlow REST server. This vulnerability allows malicious websites to bypass Same-Origin Policy protections and execute unauthorized calls against REST endpoints. An attacker can query, update, and delete experiments via the affected endpoints, leading to potential data exfiltration, destruction, or manipulation. The issue is resolved in version 3.5.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pgqp-8h46-6x4j
- Revision 1 · created ·
Published from osv record GHSA-pgqp-8h46-6x4j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-14279 Advisory: MLFlow is vulnerable to DNS rebinding attacks due to a lack of Origin header validation IDs: CVE-2025-14279, GHSA-pgqp-8h46-6x4j Record: https://patchnext.com/advisories/cve-2025-14279 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mlflow 3.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mlflow: affected < 3.5.0; fixed in 3.5.0 ## Suggested inspection (read-only) - `python -m pip show mlflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mlflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pgqp-8h46-6x4j (OSV record GHSA-pgqp-8h46-6x4j lists affected ranges: PyPI mlflow >=0 <3.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-pgqp-8h46-6x4j (GitHub-reviewed advisory GHSA-pgqp-8h46-6x4j lists affected ranges: PyPI mlflow >=0 <3.5.0) Commands are suggestions: review each one before running it.
Loading voting…