Skip to content

← Actionable
Unratedamended

Integer overflow to buffer overflow in soap HTTP parsing

CVE-2025-14181

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (php 8.5.11, 8.4.26, 8.3.35, 8.2.34; libphp 8.5.11, 8.4.26, 8.3.35, 8.2.34; php-min 8.5.11, 8.4.26, 8.3.35, 8.2.34), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Bitnami php

    Affected
    >= 8.2.0, < 8.2.34>= 8.3.0, < 8.3.35>= 8.4.0, < 8.4.26>= 8.5.0, < 8.5.11
    Fixed in
    8.3.35, 8.5.11, 8.4.26, 8.2.34
  • Bitnami libphp

    Affected
    >= 8.2.0, < 8.2.34>= 8.3.0, < 8.3.35>= 8.4.0, < 8.4.26>= 8.5.0, < 8.5.11
    Fixed in
    8.3.35, 8.5.11, 8.4.26, 8.2.34
  • Bitnami php-min

    Affected
    >= 8.2.0, < 8.2.34>= 8.3.0, < 8.3.35>= 8.4.0, < 8.4.26>= 8.5.0, < 8.5.11
    Fixed in
    8.3.35, 8.5.11, 8.4.26, 8.2.34

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2025-14181: 0.31% estimated exploitation activity in the next 30 days; percentile 24.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The SOAP HTTP client guards its response buffer growth with a check that relies on signed integer overflow, which is undefined behaviour and is not guaranteed to trigger. When the check is optimised away, a malicious SOAP server can make the client allocate a buffer far smaller than the data it then writes into it, producing a heap buffer overflow.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record BIT-php-min-2025-14181

  2. Revision 2 · amended ·

    Amended from osv record BIT-libphp-2025-14181

  3. Revision 1 · created ·

    Published from osv record BIT-php-2025-14181

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-14181

Advisory: Integer overflow to buffer overflow in soap HTTP parsing
IDs: CVE-2025-14181
Record: https://patchnext.com/advisories/cve-2025-14181 (revision 3, source checked 26 Oct 2026, 12:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: php 8.5.11, 8.4.26, 8.3.35, 8.2.34; libphp 8.5.11, 8.4.26, 8.3.35, 8.2.34; php-min 8.5.11, 8.4.26, 8.3.35, 8.2.34. A vendor fix does not mean a deployment is fixed.

## Affected components
- Bitnami php: affected >= 8.2.0, < 8.2.34; >= 8.3.0, < 8.3.35; >= 8.4.0, < 8.4.26; >= 8.5.0, < 8.5.11; fixed in 8.3.35, 8.5.11, 8.4.26, 8.2.34
- Bitnami libphp: affected >= 8.2.0, < 8.2.34; >= 8.3.0, < 8.3.35; >= 8.4.0, < 8.4.26; >= 8.5.0, < 8.5.11; fixed in 8.3.35, 8.5.11, 8.4.26, 8.2.34
- Bitnami php-min: affected >= 8.2.0, < 8.2.34; >= 8.3.0, < 8.3.35; >= 8.4.0, < 8.4.26; >= 8.5.0, < 8.5.11; fixed in 8.3.35, 8.5.11, 8.4.26, 8.2.34

## Suggested inspection (read-only)
- Bitnami php: check the installed version with your package manager.
- Bitnami libphp: check the installed version with your package manager.
- Bitnami php-min: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on php, libphp, php-min.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/BIT-php-2025-14181 (OSV record BIT-php-2025-14181 lists affected ranges: Bitnami php >=8.2.0 =8.3.0 =8.4.0 =8.5.0 <8.5.11 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-libphp-2025-14181 (OSV record BIT-libphp-2025-14181 lists affected ranges: Bitnami libphp >=8.2.0 =8.3.0 =8.4.0 =8.5.0 <8.5.11 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-php-min-2025-14181 (OSV record BIT-php-min-2025-14181 lists affected ranges: Bitnami php-min >=8.2.0 =8.3.0 =8.4.0 =8.5.0 <8.5.11 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…