Skip to content

← Actionable
High, CVSS 8.6amended

Malciously crafted QPY files can allows Remote Attackers to Cause Denial of Service in Qiskit

CVE-2025-1403GHSA-fpmr-m242-xm7x

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI qiskit

    Affected
    >= 0.45.0, < 1.3.0
    Fixed in
    1.3.0
  • PyPI qiskit-terra

    Affected
    >= 0.45.0, <= 0.46.3
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
EPSS
  • CVE-2025-1403: 0.72% estimated exploitation activity in the next 30 days; percentile 53.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A maliciously crafted QPY file containing a malformed symengine serialization stream as part of the larger QPY serialization of a ParameterExpression object can cause a segfault within the symengine library, allowing an attacker to terminate the hosting process deserializing the QPY payload. Patches This issue is addressed in 1.3.0 when using QPY format version 13. QPY format versions 10, 11, and 12 are all still inherently vulnerable if they are using symengine symbolic encoding and symengine <= 0.13.0 is installed in the deserializing environment (as of publishing there is no newer compatible release of symengine available). Using QPY 13 is strongly recommended for this reason. The symengine 0.14.0 release has addressed the segfault issue, but it is backward incompatible and will not work with any Qiskit release; it also prevents loading a payload generated with any other version of symengine. Using QPY 13 is strongly recommended for this reason. It is also strongly…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fpmr-m242-xm7x

  2. Revision 1 · created ·

    Published from osv record GHSA-fpmr-m242-xm7x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-1403

Advisory: Malciously crafted QPY files can allows Remote Attackers to Cause Denial of Service in Qiskit
IDs: CVE-2025-1403, GHSA-fpmr-m242-xm7x
Record: https://patchnext.com/advisories/cve-2025-1403 (revision 2, source checked 26 Oct 2026, 13:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: qiskit 1.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI qiskit: affected >= 0.45.0, < 1.3.0; fixed in 1.3.0
- PyPI qiskit-terra: affected >= 0.45.0, <= 0.46.3

## Suggested inspection (read-only)
- `python -m pip show qiskit`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show qiskit-terra`: prints the installed version. Run with the environment that serves production active.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on qiskit, qiskit-terra.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fpmr-m242-xm7x (OSV record GHSA-fpmr-m242-xm7x lists affected ranges: PyPI qiskit >=0.45.0 =0.45.0 <=0.46.3)
- Verified: https://github.com/advisories/GHSA-fpmr-m242-xm7x (GitHub-reviewed advisory GHSA-fpmr-m242-xm7x lists affected ranges: PyPI qiskit >=0.45.0 =0.45.0 <=0.46.3)

Commands are suggestions: review each one before running it.

Loading voting…