Skip to content

← Actionable
Medium, CVSS 5.5amended

Ansible Community General Collection is vulnerable to exposure of sensitive information

CVE-2025-14010GHSA-8ggh-xwr9-3373

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ansible 12.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ansible

    Affected
    < 12.2.0
    Fixed in
    12.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-14010: 0.19% estimated exploitation activity in the next 30 days; percentile 8.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in ansible-collection-community-general. This vulnerability allows for information exposure (IE) of sensitive credentials, specifically plaintext passwords, via verbose output when running Ansible with debug modes. Attackers with access to logs could retrieve these secrets and potentially compromise Keycloak accounts or administrative access.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8ggh-xwr9-3373

  2. Revision 1 · created ·

    Published from osv record GHSA-8ggh-xwr9-3373

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-14010

Advisory: Ansible Community General Collection is vulnerable to exposure of sensitive information
IDs: CVE-2025-14010, GHSA-8ggh-xwr9-3373
Record: https://patchnext.com/advisories/cve-2025-14010 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ansible 12.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ansible: affected < 12.2.0; fixed in 12.2.0

## Suggested inspection (read-only)
- `python -m pip show ansible`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ansible.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8ggh-xwr9-3373 (OSV record GHSA-8ggh-xwr9-3373 lists affected ranges: PyPI ansible >=0 <12.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8ggh-xwr9-3373 (GitHub-reviewed advisory GHSA-8ggh-xwr9-3373 lists affected ranges: PyPI ansible >=0 <12.2.0)

Commands are suggestions: review each one before running it.

Loading voting…