Skip to content

← Actionable
Critical, CVSS 10.0amended

NLTK has a Zip Slip Vulnerability

CVE-2025-14009GHSA-7p94-766c-hgjp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nltk 3.9.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nltk

    Affected
    <= 3.9.2
    Fixed in
    3.9.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-14009: 1.04% estimated exploitation activity in the next 30 days; percentile 63.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A critical vulnerability exists in the NLTK downloader component of nltk/nltk, affecting all versions. The unzipiter function in nltk/downloader.py uses zipfile.extractall() without performing path validation or security checks. This allows attackers to craft malicious zip packages that, when downloaded and extracted by NLTK, can execute arbitrary code. The vulnerability arises because NLTK assumes all downloaded packages are trusted and extracts them without validation. If a malicious package contains Python files, such as init.py, these files are executed automatically upon import, leading to remote code execution. This issue can result in full system compromise, including file system access, network access, and potential persistence mechanisms.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-7p94-766c-hgjp

  2. Revision 2 · amended ·

    Amended from osv record GHSA-7p94-766c-hgjp

  3. Revision 1 · created ·

    Published from ghsa record GHSA-7p94-766c-hgjp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-14009

Advisory: NLTK has a Zip Slip Vulnerability
IDs: CVE-2025-14009, GHSA-7p94-766c-hgjp
Record: https://patchnext.com/advisories/cve-2025-14009 (revision 3, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nltk 3.9.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nltk: affected <= 3.9.2; fixed in 3.9.3

## Suggested inspection (read-only)
- `python -m pip show nltk`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nltk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7p94-766c-hgjp (GitHub-reviewed advisory GHSA-7p94-766c-hgjp lists affected ranges: PyPI nltk >=0 <=3.9.2)
- Verified: https://osv.dev/vulnerability/GHSA-7p94-766c-hgjp (OSV record GHSA-7p94-766c-hgjp lists affected ranges: PyPI nltk >=0 <3.9.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…