Authentication Bypass via Default JWT Secret in NocoBase docker-compose Deployments
CVE-2025-13877GHSA-mv7p-34fv-4874
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@nocobase/auth 2.0.0-alpha.52, 1.9.23, 1.9.0-beta.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @nocobase/auth
- Affected
- >= 1.9.0, <= 1.9.21<= 1.9.0-beta.17>= 2.0.0-alpha.1, <= 2.0.0-alpha.51
- Fixed in
- 1.9.23, 2.0.0-alpha.52, 1.9.0-beta.18
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mv7p-34fv-4874 lists affected ranges: npm @nocobase/auth >=1.9.0 =0 =2.0.0-alpha.1 <2.0.0-alpha.52 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mv7p-34fv-4874 lists affected ranges: npm @nocobase/auth >=1.9.0 =0 =2.0.0-alpha.1 <=2.0.0-alpha.51
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-13877: 0.33% estimated exploitation activity in the next 30 days; percentile 25.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact CVE-2025-13877 is an authentication bypass vulnerability caused by insecure default JWT key usage in NocoBase Docker deployments. Because the official one-click Docker deployment configuration historically provided a public default JWT key, attackers can forge valid JWT tokens without possessing any legitimate credentials. By constructing a token with a known userId (commonly the administrator account), an attacker can directly bypass authentication and authorization checks. Successful exploitation allows an attacker to: - Bypass authentication entirely - Impersonate arbitrary users - Gain full administrator privileges - Access sensitive business data - Create, modify, or delete users - Access cloud storage credentials and other protected secrets The vulnerability is remotely exploitable, requires no authentication, and public proof-of-concept exploits are available. This issue is functionally equivalent in impact to other JWT secret exposure vulnerabilities such as…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mv7p-34fv-4874
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mv7p-34fv-4874
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-13877 Advisory: Authentication Bypass via Default JWT Secret in NocoBase docker-compose Deployments IDs: CVE-2025-13877, GHSA-mv7p-34fv-4874 Record: https://patchnext.com/advisories/cve-2025-13877 (revision 3, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @nocobase/auth 2.0.0-alpha.52, 1.9.23, 1.9.0-beta.18. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @nocobase/auth: affected >= 1.9.0, <= 1.9.21; <= 1.9.0-beta.17; >= 2.0.0-alpha.1, <= 2.0.0-alpha.51; fixed in 1.9.23, 2.0.0-alpha.52, 1.9.0-beta.18 ## Suggested inspection (read-only) - `npm ls @nocobase/auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @nocobase/auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mv7p-34fv-4874 (OSV record GHSA-mv7p-34fv-4874 lists affected ranges: npm @nocobase/auth >=1.9.0 =0 =2.0.0-alpha.1 <2.0.0-alpha.52 (fixed)) - Verified: https://github.com/advisories/GHSA-mv7p-34fv-4874 (GitHub-reviewed advisory GHSA-mv7p-34fv-4874 lists affected ranges: npm @nocobase/auth >=1.9.0 =0 =2.0.0-alpha.1 <=2.0.0-alpha.51) Commands are suggestions: review each one before running it.
Loading voting…