Mattermost fails to validate user permissions in Boards
CVE-2025-13870GHSA-58w6-w55x-6wq8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 8.0.0-20250905150616-ba86dfc5876b; github.com/mattermost/mattermost 10.11.5, 10.5.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- < 8.0.0-20250905150616-ba86dfc5876b
- Fixed in
- 8.0.0-20250905150616-ba86dfc5876b
Go github.com/mattermost/mattermost
- Affected
- >= 10.11.0, < 10.11.5>= 10.5.0, < 10.5.13
- Fixed in
- 10.11.5, 10.5.13
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-58w6-w55x-6wq8 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =10.11.0 =10.5.0 <10.5.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2025-13870: 0.24% estimated exploitation activity in the next 30 days; percentile 15.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to validate the user permission when accessing the files and subscribing to the block in Boards, which allows an authenticated user to access other board files and was able to subscribe to the block from other boards that the user does not have access to
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-58w6-w55x-6wq8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-13870 Advisory: Mattermost fails to validate user permissions in Boards IDs: CVE-2025-13870, GHSA-58w6-w55x-6wq8 Record: https://patchnext.com/advisories/cve-2025-13870 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 8.0.0-20250905150616-ba86dfc5876b; github.com/mattermost/mattermost 10.11.5, 10.5.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected < 8.0.0-20250905150616-ba86dfc5876b; fixed in 8.0.0-20250905150616-ba86dfc5876b - Go github.com/mattermost/mattermost: affected >= 10.11.0, < 10.11.5; >= 10.5.0, < 10.5.13; fixed in 10.11.5, 10.5.13 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. - Go github.com/mattermost/mattermost: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-58w6-w55x-6wq8 (GitHub-reviewed advisory GHSA-58w6-w55x-6wq8 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =10.11.0 =10.5.0 <10.5.13) Commands are suggestions: review each one before running it.
Loading voting…