Skip to content

← Actionable
Critical, CVSS 9.0

Mautic user without privileged access to the Marketplace can install and uninstall composer packages

CVE-2025-13828GHSA-3fq7-c5m8-g86x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 6.0.7, 5.2.9, 4.4.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mautic/core

    Affected
    >= 4.0.0, < 4.4.18>= 5.0.0, < 5.2.9>= 6.0.0, < 6.0.7
    Fixed in
    4.4.18, 5.2.9, 6.0.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2025-13828: 0.27% estimated exploitation activity in the next 30 days; percentile 18.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A non privileged user can install and remove arbitrary packages via composer for a composer based installed, even if the flag in update settings for enable composer based update is unticked. Impact A low-privileged user of the platform can install malicious code to obtain higher privileges.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3fq7-c5m8-g86x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-13828

Advisory: Mautic user without privileged access to the Marketplace can install and uninstall composer packages
IDs: CVE-2025-13828, GHSA-3fq7-c5m8-g86x
Record: https://patchnext.com/advisories/cve-2025-13828 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mautic/core 6.0.7, 5.2.9, 4.4.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mautic/core: affected >= 4.0.0, < 4.4.18; >= 5.0.0, < 5.2.9; >= 6.0.0, < 6.0.7; fixed in 4.4.18, 5.2.9, 6.0.7

## Suggested inspection (read-only)
- Packagist mautic/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mautic/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3fq7-c5m8-g86x (GitHub-reviewed advisory GHSA-3fq7-c5m8-g86x lists affected ranges: Packagist mautic/core >=4.0.0 =5.0.0 =6.0.0 <6.0.7)

Commands are suggestions: review each one before running it.

Loading voting…