Mattermost doesn't validate user channel membership when attaching Mattermost posts as comments to Jira issues
CVE-2025-13767GHSA-fmqf-pmcm-8cx9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 8.0.0-20251121122154-b57c297c6d7; github.com/mattermost/mattermost-server 11.1.1, 11.0.6, 10.12.4, 10.11.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- < 8.0.0-20251121122154-b57c297c6d7
- Fixed in
- 8.0.0-20251121122154-b57c297c6d7
Go github.com/mattermost/mattermost-server
- Affected
- >= 10.11.0, < 10.11.8>= 10.12.0, < 10.12.4>= 11.0.0, < 11.0.6>= 11.1.0, < 11.1.1
- Fixed in
- 10.11.8, 10.12.4, 11.0.6, 11.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fmqf-pmcm-8cx9 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =10.11.0 =10.12.0 =11.0.0 =11.1.0 <11.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2025-13767: 0.19% estimated exploitation activity in the next 30 days; percentile 9.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 11.1.x <= 11.1.0, 11.0.x <= 11.0.5, 10.12.x <= 10.12.3, 10.11.x <= 10.11.7 fails to validate user channel membership when attaching Mattermost posts as comments to Jira issues, which allows an authenticated attacker with access to the Jira plugin to read post content and attachments from channels they do not have access to.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fmqf-pmcm-8cx9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-13767 Advisory: Mattermost doesn't validate user channel membership when attaching Mattermost posts as comments to Jira issues IDs: CVE-2025-13767, GHSA-fmqf-pmcm-8cx9 Record: https://patchnext.com/advisories/cve-2025-13767 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 8.0.0-20251121122154-b57c297c6d7; github.com/mattermost/mattermost-server 11.1.1, 11.0.6, 10.12.4, 10.11.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected < 8.0.0-20251121122154-b57c297c6d7; fixed in 8.0.0-20251121122154-b57c297c6d7 - Go github.com/mattermost/mattermost-server: affected >= 10.11.0, < 10.11.8; >= 10.12.0, < 10.12.4; >= 11.0.0, < 11.0.6; >= 11.1.0, < 11.1.1; fixed in 10.11.8, 10.12.4, 11.0.6, 11.1.1 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. - Go github.com/mattermost/mattermost-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fmqf-pmcm-8cx9 (GitHub-reviewed advisory GHSA-fmqf-pmcm-8cx9 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =10.11.0 =10.12.0 =11.0.0 =11.1.0 <11.1.1) Commands are suggestions: review each one before running it.
Loading voting…