pretix has Email Content Injection Through Maliciously Formatted Names
CVE-2025-13742GHSA-2mm6-624x-fqrr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pretix 2025.9.2, 2025.8.2, 2025.7.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pretix
- Affected
- >= 1.0.0, < 2025.7.3>= 2025.8.0, < 2025.8.2>= 2025.9.0, < 2025.9.2
- Fixed in
- 2025.9.2, 2025.7.3, 2025.8.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2mm6-624x-fqrr lists affected ranges: PyPI pretix >=1.0.0 =2025.8.0 =2025.9.0 <2025.9.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2mm6-624x-fqrr lists affected ranges: PyPI pretix >=1.0.0 =2025.8.0 =2025.9.0 <2025.9.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.4 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:L/VA:L/SC:N/SI:L/SA:L/E:U · score source
- EPSS
- CVE-2025-13742: 0.20% estimated exploitation activity in the next 30 days; percentile 9.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Emails sent by pretix can utilize placeholders that will be filled with customer data. For example, when {name} is used in an email template, it will be replaced with the buyer's name for the final email. If the name of the attendee contained HTML or Markdown formatting, this was rendered as HTML in the resulting email. This way, a user could inject links or other formatted text through a maliciously formatted name. Since pretix applies a strict allow list approach to allowed HTML tags, this could not be abused for XSS or similarly dangerous attack chains. However, it can be used to manipulate emails in a way that makes user-provided content appear in a trustworthy and credible way, which can be abused for phishing.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2mm6-624x-fqrr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-2mm6-624x-fqrr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-13742 Advisory: pretix has Email Content Injection Through Maliciously Formatted Names IDs: CVE-2025-13742, GHSA-2mm6-624x-fqrr Record: https://patchnext.com/advisories/cve-2025-13742 (revision 3, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pretix 2025.9.2, 2025.8.2, 2025.7.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pretix: affected >= 1.0.0, < 2025.7.3; >= 2025.8.0, < 2025.8.2; >= 2025.9.0, < 2025.9.2; fixed in 2025.9.2, 2025.7.3, 2025.8.2 ## Suggested inspection (read-only) - `python -m pip show pretix`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pretix. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2mm6-624x-fqrr (OSV record GHSA-2mm6-624x-fqrr lists affected ranges: PyPI pretix >=1.0.0 =2025.8.0 =2025.9.0 <2025.9.2 (fixed)) - Verified: https://github.com/advisories/GHSA-2mm6-624x-fqrr (GitHub-reviewed advisory GHSA-2mm6-624x-fqrr lists affected ranges: PyPI pretix >=1.0.0 =2025.8.0 =2025.9.0 <2025.9.2) Commands are suggestions: review each one before running it.
Loading voting…